Bug 571235 - small patch to fix error message on slapd startup
Summary: small patch to fix error message on slapd startup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openldap
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jan Zeleny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 575723 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-07 18:54 UTC by Leo Bergolth
Modified: 2010-07-14 22:55 UTC (History)
2 users (show)

Fixed In Version: openldap-2.4.19-4.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-09 01:30:09 UTC
Type: ---


Attachments (Terms of Use)
Patch to avoid error message on slapd startup (478 bytes, patch)
2010-03-07 18:54 UTC, Leo Bergolth
no flags Details | Diff

Description Leo Bergolth 2010-03-07 18:54:05 UTC
Created attachment 398364 [details]
Patch to avoid error message on slapd startup

Description of problem:

When using overlays, the per database overlay configuration is saved in a database specific subdirectory. (See the syncprov example below.)
-------------------- 8< --------------------
# find cn\=config/olcDatabase*
cn=config/olcDatabase={0}config.ldif
cn=config/olcDatabase={1}bdb
cn=config/olcDatabase={1}bdb/olcOverlay={0}syncprov.ldif
cn=config/olcDatabase={1}bdb.ldif
cn=config/olcDatabase={-1}frontend.ldif
cn=config/olcDatabase={2}monitor.ldif
-------------------- 8< --------------------

This causes problems on slapd-startup because the olcDatabase* glob in the init-script also lists the directory:

-------------------- 8< --------------------
+ for configfile in '`ls -1 $configdir/cn\=config/olcDatabase*`'                                                     
LANG=C egrep '^olcDbDirectory[[:space:]]*:[[:space:]]+[[:print:]]+$' $configfile | sed 's,^olcDbDirectory: ,,'       
++ LANG=C                                                                                                            
++ egrep '^olcDbDirectory[[:space:]]*:[[:space:]]+[[:print:]]+$' '/etc/openldap/slapd.d//cn=config/olcDatabase={1}bdb:'                                                                                                                   
egrep: /etc/openldap/slapd.d//cn=config/olcDatabase={1}bdb:: No such file or directory                               
-------------------- 8< --------------------

The attached patch fixes the problem.

Version-Release number of selected component (if applicable):
2.4.21-4

Cheers,
--leo

Comment 1 Fedora Update System 2010-03-16 15:11:37 UTC
openldap-2.4.21-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/openldap-2.4.21-5.fc13

Comment 2 Fedora Update System 2010-03-17 13:05:40 UTC
openldap-2.4.19-4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/openldap-2.4.19-4.fc12

Comment 3 Fedora Update System 2010-03-18 03:24:45 UTC
openldap-2.4.21-5.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openldap'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/openldap-2.4.21-5.fc13

Comment 4 Fedora Update System 2010-03-20 03:43:40 UTC
openldap-2.4.19-4.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openldap'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/openldap-2.4.19-4.fc12

Comment 5 Jan Zeleny 2010-03-22 09:10:00 UTC
*** Bug 575723 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2010-04-09 01:29:56 UTC
openldap-2.4.19-4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2010-06-30 17:36:08 UTC
openldap-2.4.21-8.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/openldap-2.4.21-8.fc13

Comment 8 Fedora Update System 2010-07-14 22:55:01 UTC
openldap-2.4.21-8.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.