Bug 57146 - RFE: Kickstart over serial console does not display progress
RFE: Kickstart over serial console does not display progress
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-05 14:26 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-10 02:44:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-12-05 14:26:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-13 i686)

Description of problem:
When kickstart-ing a machine over serial console the entire installaion
takes place without any output on the serial console.
This happens even if the installation kernel is started with
"append serial console=ttyS0,38400 console=tty0"

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.make a kickstart floppy with serial console defined
2.boot your machine with that floppy
3.listen on the serial port and watch the (not appearing) output from
  anaconda

Actual Results:  When the installation kernel boots, it outputs messages
over the
serial console but anaconda does not output anything.


Expected Results:  I would like to see the anaconda progress report on the
serial console.


Additional info:

The anaconda output is redirected into a file locally on the machine
you install. I would like to see some sort of progress report over
the serial console line in order to detect (e.g.) hanging installations
etc.
This is actually not a bug because that never worked and never was
supposed to work.
Comment 1 Jeremy Katz 2001-12-12 15:27:49 EST
Deferring for consideration in a future release.
Comment 2 Need Real Name 2002-09-30 16:20:40 EDT
This problem can be fixed by simply reversing the order of the "console"
definitions in the kernel append line:

"append serial console=tty0 console=ttyS0,38400"

works just fine.

-- Alf.
Comment 3 Jeremy Katz 2003-01-10 02:44:52 EST
C

Note You need to log in before you can comment on or make changes to this bug.