Bug 5715 - PCMCIA no longer works with RH6.x boot images on Armada 7750
PCMCIA no longer works with RH6.x boot images on Armada 7750
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Depends On:
  Show dependency treegraph
Reported: 1999-10-08 04:53 EDT by havard.bjastad
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-02-24 11:22:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description havard.bjastad 1999-10-08 04:53:48 EDT
I have been using RH5.2 for quite some time on my Compaq
Armada 7750 laptop and the PCMCIA cards have been
functioning great. Recently, I decided to upgrade to RH6.0
and went through the upgrade process. Upon completion I was
prompted to reboot, which I did. The boot process got as far
as to the PCMCIA module, where it hung. I tried rebooting
several times, with and without PCMCIA cards in the slots,
but with the same result.

OK, so an upgrade may not be possible. Hating the idea of
loosing my data and configuration files (of course, I
skipped the backup before upgrading), I saw no other way out
than making a full RH6.0 install. I went through the entire
process (even repartitioned the hard drive), but with the
same result.

Now with RH6.1 out, I decided to give it a new shot. After
hours of downloading the whole package, I eagerly went
ahead. Unable to create a bootable CD, I decided to go for
an HTTP install, which would have to go through my PCMCIA
network card. So I created a boot disk based on the
pcmcia.img and rebooted the machine. AND THEN THE SAME THING
HAPPENS - when trying to initialize PCMCIA the whole machine
hangs! Again, I tried with and without PCMCIA cards
inserted, but to no avail. So my conclusion is that the boot
image(s) that ships with RH6.x for some reason DOES NOT
WORK! Note that everything was fine with RH5.2. And
everything works fine with Win95. And WinNT.

I've tried it on a couple of my colleague's laptops and
Armada 4220 works fine, while all the Armada 7750 have the
same problem as mine. Do you know of this problem? Do you
know any workarounds?

Until the problem is resolved I'll just have to stroll along
with Windows, please help me out here...

Havard Bjastad
Andersen Consulting

Note You need to log in before you can comment on or make changes to this bug.