Bug 57182 - Bad arch under Solaris on Intel hardware
Summary: Bad arch under Solaris on Intel hardware
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-06 15:57 UTC by Gary Benson
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-06 15:57:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gary Benson 2001-12-06 15:57:49 UTC
Solaris' uname, when run on Intel hardware, reports the machine type as
"i86pc" rather than the usual "i386". This causes all manner of problems
due to i86pc not being in the compatibility tables.

Fix:
--- rpm-4.0.3-vanilla/lib/rpmrc.c       Wed Aug 15 14:01:35 2001
+++ rpm-4.0.3/lib/rpmrc.c       Wed Aug 15 14:01:35 2001
@@ -1042,6 +1042,12 @@
            else /* Solaris 2.x: n.x.x becomes n-3.x.x */
                sprintf(un.sysname, "solaris%1d%s", atoi(un.release)-3,
                        un.release+1+(atoi(un.release)/10));
+
+           /* Solaris on Intel hardware reports i86pc instead of i386
+            * (at least on 2.6 and 2.8)
+            */
+           if (!strcmp(un.machine, "i86pc"))
+               sprintf(un.machine, "i386");
        }
        else if (!strcmp(un.sysname, "HP-UX"))
            /*make un.sysname look like hpux9.05 for example*/

Comment 1 Jeff Johnson 2001-12-09 20:20:06 UTC
Fixed in CVS, should be in rpm-4.0.4-0.3 and later.


Note You need to log in before you can comment on or make changes to this bug.