Bug 572005 - Unable to adjust the brightness of the LCD panel on Asus F9DC
Unable to adjust the brightness of the LCD panel on Asus F9DC
Status: CLOSED DUPLICATE of bug 572896
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-09 19:11 EST by Tommy He
Modified: 2010-03-12 09:20 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-12 09:20:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg information (43.31 KB, application/octet-stream)
2010-03-09 19:11 EST, Tommy He
no flags Details
gnome-power-bugreport information (2.00 KB, application/octet-stream)
2010-03-10 05:14 EST, Tommy He
no flags Details

  None (edit)
Description Tommy He 2010-03-09 19:11:10 EST
Created attachment 398970 [details]
dmesg information

Description of problem:


Version-Release number of selected component (if applicable):
gnome-power-manager-2.29.2-1.fc13

How reproducible:

Steps to Reproduce:
1. Start GNOME DE.
2. Close the lid of the laptop. It goes into suspend automatically without problem.
3. Open the lid and resume the laptop.
  
Actual results:
The LCD panel is dim and there is no way to adjust the brightness. No slider in gnome-power-preference. Gnome-panel brightness applet says 'unable to acquire the brightness of the laptop'. Keyboard shortcuts do not work, either. Logout or restart make no difference. 

Expected results:
Automatically restore to the previous brightness after resume. A slider in gnome-power-preference to adjust the brightness. Applet and keyboard work.


Additional info:

The problem persists no matter I use nvidia binary driver 195.36.08 from rpmfusion or nouveau gallium3d. Running the same nvidia binary driver on Fedora 12 does not have this issue.

Smolts: http://www.smolts.org/client/show/pub_0b8133aa-815e-4c11-9e5f-f5ca20f88bb6


The only way I can adjust the brightness is to use a Fedora 12 LiveCD.
Comment 1 Tommy He 2010-03-09 19:52:21 EST
Fedora 13 Alpha LiveCD KDE spin does not have this issue while GNOME spin has.
Both running on the same laptop with nouveau driver.

So I assume it would be a gnome-power-manager problem.
Comment 2 Tommy He 2010-03-09 20:35:04 EST
Switching to KDE DE gives me the ability to adjust the brightness again.
Tested on the same laptop with nvidia binary 195.36.08 driver.
Comment 3 Tommy He 2010-03-10 05:14:41 EST
Created attachment 399043 [details]
gnome-power-bugreport information
Comment 4 Paul Barnett 2010-03-10 23:12:36 EST
same problem here on dell inspiron 1755 - and happens even before suspend/resume (ie unable to change screen brightness in gnome, kde works ok).

fedora 13 installed from alpha rc4 live, + all updates

video is
01:00.0 VGA compatible controller: ATI Technologies Inc M92 LP [Mobility Radeon HD 4300 Series]
Comment 5 Nigel Jones 2010-03-11 15:16:46 EST
Same problem here too
Chipset: "ATI Mobility Radeon HD 3650" (ChipID = 0x
9591)

Occurs with KMS off and on.
Comment 6 Nigel Jones 2010-03-11 15:17:23 EST
Workaround is

echo 15 > /sys/devices/virtual/backlight/acpi_video0/brightness

or similar
Comment 7 carlo 2010-03-12 04:18:11 EST
same problem for me 

uname -a
Linux fedora13 2.6.33-1.fc13.x86_64 #1 SMP Wed Feb 24 19:55:32 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

[cab@fedora13 ~]$ lsmod | grep radeo
radeon                584397  2 
ttm                    51501  1 radeon
drm_kms_helper         24736  1 radeon
drm                   173761  4 radeon,ttm,drm_kms_helper
i2c_algo_bit            5037  1 radeon
i2c_core               25706  5 videodev,radeon,drm_kms_helper,drm,i2c_algo_bit

01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3400 Series


laptop asus 

description: Notebook
    product: F5SR
    vendor: ASUSTeK Computer Inc.
    version: 1.0
Comment 8 Michal Schmidt 2010-03-12 04:48:20 EST
Please see bug 572896 and test the scratch build referenced there (x86_64 only). If it works, close this bug as a duplicate of 572896. Thanks.
Comment 9 Michal Schmidt 2010-03-12 04:56:49 EST
Alright, I see that Tommy He uses i686, so I've now started an i686 scratch build too:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2048407
Comment 10 Tommy He 2010-03-12 07:52:29 EST
(In reply to comment #9)
> Alright, I see that Tommy He uses i686, so I've now started an i686 scratch
> build too:
> http://koji.fedoraproject.org/koji/taskinfo?taskID=2048407    

Sadly, it does not work with :-)

http://koji.fedoraproject.org/koji/buildinfo?buildID=161370
Comment 11 Michal Schmidt 2010-03-12 09:04:10 EST
(In reply to comment #10)
> 
> Sadly, it does not work with :-)
> 
> http://koji.fedoraproject.org/koji/buildinfo?buildID=161370    

I know. That's gnome-power-manager-2.29.91-2.fc13 which is known to have the bug.

> (In reply to comment #9)
> > Alright, I see that Tommy He uses i686, so I've now started an i686 scratch
> > build too:
> > http://koji.fedoraproject.org/koji/taskinfo?taskID=2048407    

But what about this scratch build instead? From your comment I did not quite understand whether you tried it or not.
Comment 12 Tommy He 2010-03-12 09:19:56 EST
(In reply to comment #11)
> (In reply to comment #10)
> > 
> > Sadly, it does not work with :-)
> > 
> > http://koji.fedoraproject.org/koji/buildinfo?buildID=161370    
> 
> I know. That's gnome-power-manager-2.29.91-2.fc13 which is known to have the
> bug.
> 
> > (In reply to comment #9)
> > > Alright, I see that Tommy He uses i686, so I've now started an i686 scratch
> > > build too:
> > > http://koji.fedoraproject.org/koji/taskinfo?taskID=2048407    
> 
> But what about this scratch build instead? From your comment I did not quite
> understand whether you tried it or not.    

Sorry, my fault. I did not notice the m1 tag. I thought it was the one I tested yesterday.

Yes, the scratch build works.

I am going to close this bug.
Comment 13 Tommy He 2010-03-12 09:20:38 EST

*** This bug has been marked as a duplicate of bug 572896 ***

Note You need to log in before you can comment on or make changes to this bug.