Bug 57219 - Network crashes when under load (such as downloading files)
Network crashes when under load (such as downloading files)
Status: CLOSED DUPLICATE of bug 56058
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-06 22:00 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-04 06:10:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-12-06 22:00:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Networking was fine with RH 7.1 on the same machine. After doing a clean 
install of RH 7.2 I immediately began seeing network failures. I did 
another clean reinstall producing the same results. The net will seem OK 
until I try to download something using (lynx, netscape, ftp, etc.) It 
seems that the additional load of the download will cause a hang/stall 
never to recover. After failure I will Ctl<C> out of the program and do a 
ifdown/ifup. This will bring the net back up. It will fail consistantly 
any time I try to download. I am using a static IP connecting to a hub 
connecting to a LinkSys router. I have tried reconfiguring several times 
with different IP's with the same result.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Try to download a file using Netscape, Lynx, FTP, etc..
2.The download process will stall/hang
3.Ctl<C> out of the program.
4.Do ifdown/ifup.
5.Repeat the process to cause another failure. 
	

Actual Results:  The network will stall/hang/fail.

Expected Results:  A succesful file download

Additional info:

1)I have a Toshiba 2805-S402 Satellite with a Pentium 850 and 256M RAM.
2)The only error messages I have seen (in messages) is:
kernel: NETDEV WATCHDOG: eth0: transmit times out
kernel: eth0: Transmit timed out: status 0050 0c80 at 504/532 command 
200c0000
Comment 1 Need Real Name 2001-12-08 22:43:18 EST
The network also crashes with normal browser (surfing) usage.
Comment 2 Arjan van de Ven 2001-12-13 04:00:01 EST
Any idea what network card this is ?
Comment 3 Need Real Name 2001-12-13 10:47:18 EST
Yes, it is an Intel Pro/100 VE.
Comment 4 Arjan van de Ven 2001-12-13 10:52:01 EST
Ok then I have recently made a kernel with a fix for eepro100 crashes:
http://people.redhat.com/arjanv/testkernels
I'd be very interested to know if this kernel fixes your problem too....
Comment 5 Need Real Name 2001-12-13 14:00:45 EST
I installed your fixed kernel (2.4.9-17.6) and have been testing it for several 
minutes. The results are the same. When I download (or browse) the network 
fails.
Comment 6 Need Real Name 2001-12-19 10:23:20 EST
Anything else I can do to aid in debug? Do you want me to attach log files, 
config. info., etc..
Comment 7 Arjan van de Ven 2001-12-19 10:28:32 EST
You can try to use the e100 module instead (by replacing "eepro100" with "e100"
in  the /etc/modules.conf file)... it has a few more workarounds for hardware
issues.
Comment 8 Need Real Name 2001-12-19 11:44:10 EST
As per your advice I installed the e100 module. I have been testing it for a 
few minutes and it seems to be working. I have downloaded some large files that 
always produced failure with the eepro100 module. What is the downside to using 
the e100 module versus the eepro100? (performance?). I am using it in 
conjunction with your (2.4.9-17.6) kernel. Is this OK? Will it be stable? Will 
there be a fix to the eepro100 module in the near future? Thanks for the help...
Comment 9 Arjan van de Ven 2001-12-19 13:19:57 EST
the quality of the e100 driver implementation is rather poor; however in normal
cases you won't notice it; in corner cases (such as network error conditions)
the driver can freeze your system for several seconds though... however that
still beats not working at all ;(
Comment 10 Need Real Name 2001-12-19 14:42:12 EST
Will there be a fix for the eepro100 driver in the near future?
Comment 11 Arjan van de Ven 2002-01-04 06:09:58 EST
We're doing what we can, but Intel is "not exactly helpful" with this.
Comment 12 Arjan van de Ven 2002-02-11 12:14:15 EST

*** This bug has been marked as a duplicate of 56058 ***
Comment 13 Gordon Messmer 2002-03-04 13:23:43 EST
This bug may not be a duplicate of #56058.  The kernel messages are different. 
This sounds like the APIC problem (maybe) that seems to affect a lot of ne2k-pci
users (I just got bit by this).

There's a patch which may fix the problem here:
http://groups.google.com/groups?q=ne2k-pci+linux+2.4+WATCHDOG&hl=en&selm=linux.kernel.9uoige%24cq4%241%40lyon.ram.loc&rnum=1

It's speculation on my part, but I thought I'd suggest it.  I'm testing the
latest errata kernel on my machine now, after the APIC problem left it down all
weekend.

Note You need to log in before you can comment on or make changes to this bug.