Bug 57220 - libstdc++ 3.1-0.10 fails dependencies
libstdc++ 3.1-0.10 fails dependencies
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: libstdc++ (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-06 22:41 EST by sean
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-08 11:33:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean 2001-12-06 22:41:00 EST
Description of Problem:
rpm -Fvh fails because of dependencies on libstdc++-libc6.2-2.so.3. Is it
in fact included in 3.1-0.10? Is there a compatibility library?

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:

This is a snippet from rpm -Fvvh for the 3.1-0.10 rpm files:

....................................
D: ========== --- libstdc++-2.96-101
D:  Requires: libstdc++-libc6.2-2.so.3                      NO
D: package switchdesk-kde-3.9.7-2 require not satisfied:
libstdc++-libc6.2-2.so.3
D:  Requires: R libstdc++-libc6.2-2.so.3                    NO  (cached)
D: package groff-1.17.2-3 require not satisfied: libstdc++-libc6.2-2.so.3
D:  Requires: R libstdc++-libc6.2-2.so.3                    NO  (cached)
D: package kdelibs-2.2-11 require not satisfied: libstdc++-libc6.2-2.so.3
D:  Requires: R libstdc++-libc6.2-2.so.3                    NO  (cached)
D: package kdepim-2.2-1 require not satisfied: libstdc++-libc6.2-2.so.3
D:  Requires: R libstdc++-libc6.2-2.so.3                    NO  (cached)
..................................
goes on for about 20 programs.


esults:


Additional Information:
Comment 1 Jakub Jelinek 2001-12-08 15:02:31 EST
You need to install compat-libstdc++-7.2-2.96.101.9 too.

Note You need to log in before you can comment on or make changes to this bug.