Bug 572576 - After installation with an existing home, login has errors and can't login to home
After installation with an existing home, login has errors and can't login to...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-11 10:35 EST by Oded Arbel
Modified: 2010-09-15 07:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-15 07:47:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Oded Arbel 2010-03-11 10:35:47 EST
Description of problem:
I installed Fedora 13 branched nightly compose from today (not rawhide) from the live KDE CD (copied to a USB drive because I didn't have empty media available). Installation went without a problem and in the post install screen I configure to "create home directories on first login" (because I plan to use network login on the workstation).

The home partition was not formatted from a previous Linux installation and when I create a user for which a home directory already exists I was notified that the permissions on the existing dir will be changed. That was very nice.

After all that is done, log in from the console looks like this:
---8<---
workstation login: username
Password: ****
Creating directory '/home/username'
Last login: Thu Mar 11 19:25:34 on tty3
No directory /home/username!
Logging in with home = "/".
username@workstation:/$
---8<---
/home/username exists and has the correct permissions (the create user process did that ok). At this point if I execute 'cd', I'm moved to my home directory and everything looks fine.

The /home partition is not auto-mounted or anything, and logging out and back in produces the exact same input.

I also can't login using the KDE login manager, possibly due to this or due to another problem - I haven't investigated it properly yet.

Version-Release number of selected component (if applicable):
6.0.2-1.fc13.x86_64
Comment 1 Oded Arbel 2010-03-11 10:41:23 EST
Regarding the KDM login: when I try that, I get a nice dialog box saying "creating home directory" and when I OK that I get a "Logging in with /" dialog - same as a console login.

Then I get an old style X dialog box (not KDE or GNOME) which says "kstartupconfig4 does not exist or fails. The error code is 3. Check your installation", and an "okay" button. 

/usr/bin/kstartupconfig4 exists and I can run it as a user from the console, in which case it does nothing, so I think the problem is indeed the login issue.
Comment 2 Tomas Mraz 2010-03-11 10:43:14 EST
Could it be that it is some kind of SELinux problem?

Note that the pam_mkhomedir does not currently work completely correctly in regards to SELinux labels.
Comment 3 Tomas Mraz 2010-03-11 10:44:30 EST
Could you try restorecon -R /home/username as root and then try to login again?
Comment 4 Oded Arbel 2010-03-11 11:07:43 EST
After replacing KDM with GDM, the login completes fine, so the login problem looks to me be only affecting KDM. That may warrant another bug report.
Comment 5 Oded Arbel 2010-03-11 11:09:41 EST
Indeed, restorecon solved the login problem in both console and KDM.

The create user step in the first run wizard talked about setting SELinux security contexts, so it looks to have failed in doing that - should that be the fix?
Comment 6 Tomas Mraz 2010-03-29 08:52:29 EDT
Maybe this failed somehow.
Comment 7 Tomas Mraz 2010-09-15 07:47:05 EDT
Unfortunately I cannot reproduce this. If you have reproduceable testcase in the current Fedora please reopen.

Note You need to log in before you can comment on or make changes to this bug.