Bug 57263 - evolution-1.0-1.src.rpm won't build
evolution-1.0-1.src.rpm won't build
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: evolution (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-07 19:59 EST by sean
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-14 22:25:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean 2001-12-07 19:59:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.16 i686)

Description of problem:
Here's a snippet from rpm --rebuild evolution
...................................
config.status: creating config.h
config.status: executing default-1 commands
config.status: executing default-2 commands
config.status: executing default-3 commands
configure: configuring in libical
configure: running /bin/sh './configure' --prefix=/usr  i386-redhat-linux
--exec
-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc
--datadir=/
usr/share --includedir=/usr/include --libdir=/usr/lib
--libexecdir=/usr/libexec 
--localstatedir=/var --sharedstatedir=/usr/com --mandir=/usr/share/man
--infodir
=/usr/share/info --with-nspr-includes=/usr/include/mozilla/nspr
--with-nspr-libs
=/usr/lib
--with-db3-includes=/usr/src/redhat/BUILD/evolution-1.0/db-3.1.17/buil
d_unix
--with-db3-libs=/usr/src/redhat/BUILD/evolution-1.0/db-3.1.17/build_unix 
--with-static-nss-libs=/usr/src/redhat/BUILD/evolution-1.0/nss-3.3.1/lib
--with-
nss-includes=/usr/src/redhat/BUILD/evolution-1.0/nss-3.3.1/include
--with-openss
l-includes=no --enable-gtk-doc=no --enable-file-locking=fcntl
--enable-dot-locki
ng=no --with-openldap=yes --enable-pilot-conduits=yes --enable-nntp=yes
--with-k
rb5=/usr/kerberos 'CFLAGS=-O2 -march=i386 -mcpu=i686'
build_alias=i386-redhat-li
nux host_alias=i386-redhat-linux target_alias=i386-redhat-linux
--cache-file=/de
v/null --srcdir=.
configure: warning: CFLAGS=-O2 -march=i386 -mcpu=i686: invalid host type
configure: error: can only configure for one host and one target at a time
configure: error: /bin/sh './configure' failed for libical
error: Bad exit status from /var/tmp/rpm-tmp.70177 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.70177 (%build)


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm --rebuild evolution
2.
3.
	

Additional info:
Comment 1 sean 2001-12-07 22:26:28 EST
Tried evolution-1.0-1.7.2. Same result.

jay
Comment 2 Jeremy Katz 2001-12-14 01:02:47 EST
What version of autoconf and automake  do you have installed?
Comment 3 sean 2001-12-14 15:17:38 EST
[system@localhost tmp]$ rpm -q autoconf
autoconf-2.52-4
[system@localhost tmp]$ rpm -q automake
automake-1.5-1
Comment 4 sean 2001-12-14 19:46:09 EST
changed to automake -1.4p5-3. same result.
Comment 5 Jeremy Katz 2001-12-14 22:25:23 EST
It looks like there's something different in how autoconf 2.52 is handling
AC_CONFIG_SUBDIRS...  should work with 2.13 and I'm trying to get a better
handle on how/why the autoconf behavior has changed
Comment 6 Jeremy Katz 2001-12-18 15:45:59 EST
Fixed for next build as well as being fixed in upstream CVS on both the 1-0
branch and HEAD

Note You need to log in before you can comment on or make changes to this bug.