Bug 57269 - adsl-start works in kernel 2.4.2-2 and fails in 2.4.9-12
adsl-start works in kernel 2.4.2-2 and fails in 2.4.9-12
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rp-pppoe (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-07 22:57 EST by Vladimir Tkachenko
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-13 09:51:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Tkachenko 2001-12-07 22:57:32 EST
Description of Problem:
When upgrade from 2.4.2-2 to new versions up to 2.4.9-12 adsl-start stops
working

Version-Release number of selected component (if applicable):
2.4.9-12

How Reproducible:


Steps to Reproduce:
1.  Login to original 2.4.2-2 kernel

# uname -r
2.4.2-2
# adsl-start
... Connected!

2.  Login to new kernel
# uname -r
2.4.9-12
# adsl-start
................TIMED OUT
/usr/sbin/adsl-start: line 192:   985 Terminated              $CONNECT "$@"
>/dev/null 2>&1

Actual Results:
timeout of adsl-start. "Link" light goes off untill restart linux.

Expected Results:
"Link" light is off for halh a second, then on. Connected.


Additional Information:
Comment 1 Arjan van de Ven 2001-12-13 03:56:31 EST
Since I have no idea what adsl-start does/needs I'll assign this to the package
of that for now
Comment 2 Ngo Than 2001-12-13 09:51:25 EST
please update ppp-2.4.1-2 on your system and try again
Comment 3 Ngo Than 2001-12-18 06:08:34 EST
i cannot reproduce it on my home machine. It works correct with kernel-2.4.9-2,
rp-pppoe-2.6-5 and ppp-2.4.0-2.

It should be a bug on your provider side.
Comment 4 Vladimir Tkachenko 2001-12-20 23:22:59 EST
Hello,

1. You can see all info at www.redhat.com/support,  Service Request 195420.
    When I got response below, I submit bug to bugzilla:

"We regret to inform you that your concern is due to a bug with the new kernel.
We suggest that you submit a bugzilla entry by visiting this link:
http://bugzilla.redhat.com"

2. >i cannot reproduce it on my home machine. It works correct with
kernel-2.4.9-2,

I had problem with kernel 2.4.9-12

3.>  please update ppp-2.4.1-2 on your system and try again

I used both version from RH CD and latest. Again, all info is in Service Request
195420

4.> It should be a bug on your provider side.

My internet connection works in windows and original RH Linux. It doesn't work
with pppoe at any new kernel I updated using up2date.
Now I use other way to connect to internet (the same provider). It's working
even with kernel which doesn't allow pppoe.

What is the reason to say it's a bug on  provider side?

I am not interesting about fixing this anymore. Just think finding a bug means
improve Linux.

Thanks,
Vladimir Tkachenko

Note You need to log in before you can comment on or make changes to this bug.