Bug 57274 - kernel >2.4.16-pre1 compile failures from segfaults
kernel >2.4.16-pre1 compile failures from segfaults
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-08 02:14 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-08 13:27:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-12-08 02:14:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.6) Gecko/20011120

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. save configs from last kernel
2. unpack linux-2.4.16.tar.bz2
3. unpack patch-2.4.17-pre6
4. mv linux-2.4.16 linux-2.4.17-pre6
5. rm -f linux #old link
6. ln -s linux-2.4.17-pre6 linux
7. cd linux
8. patch -p1 <../patch-$VERP
9. copy in old configs saved above
10. make oldconfig
11. make xconfig to set rtc to utc
12. edit 'makeit' to reflect the right versions
13. run ./makeit, which is equivalent to:
14. make dep
15. make clean
16. make bzImage
17. move old vmlinuz out of the way my renaming
18. cp bzImage to /boot as vmlinuz-$VER
19. make modules
20. move old modules by renaming
21. make modules_install
22. copy System.map and reset /boot links
23. depmod -a $VER
24. lilo -v


Actual Results:  fails at make bzImage with this error return:
gcc -D__KERNEL__ -I/mnt/hdc1/src/linux-2.4.17-pre6/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fomit-frame-pointer
-fno-strict-aliasing -fno-common -pipe -mpreferred-stack-boundary=2
-march=k6    -c -o root.o root.c
In file included from
/mnt/hdc1/src/linux-2.4.17-pre6/include/linux/byteorder/little_endian.h:66,
                 from
/mnt/hdc1/src/linux-2.4.17-pre6/include/asm/byteorder.h:45,
                 from /mnt/hdc1/src/linux-2.4.17-pre6/include/linux/fs.h:200,
                 from devpts_i.h:13,
                 from root.c:17:
/mnt/hdc1/src/linux-2.4.17-pre6/include/linux/byteorder/generic.h:0:
Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.


Expected Results:  obviously the compile should have succeeded, but I've
had similar results where ld failed for kernel-2.4.17-pre1, so I'm stuck at
2.4.16-pre1, which I first built with 2.96-97, and which rebuilds with
2.96-101 just fine.

Additional info:

gcc is 2.96-101, full install of all components
cpu is a K6-III running at 500 mhz
Comment 1 Arjan van de Ven 2001-12-08 03:32:56 EST
gcc is segfaulting, not the kernel
Comment 2 Jakub Jelinek 2001-12-08 08:06:03 EST
Is it reproduceable always on the same file messages?
If not, it is in 99.9% hardware problem, if yes, please attach preprocessed
source file (root.i) on which this can be reproduced (you can e.g. use
gcc -save-temps option to create it).
Comment 3 Need Real Name 2001-12-08 13:27:08 EST
I've no idea how it happened, but according to gnorpm, I had both gcc-2.96-98 and gcc3 installed.
I've removed gcc3, and two compiles have now run to completion via my ./makeit script.

Two more attempts have now hung the machine requireing a reset button, but this
seems to be related to my attempts to make sane find my new scanner, an Epson 1250U.

I've also removed from the kernel 2.4.17-pre6 building right now, the pdc202xx suppport
as I've removed the card from that machine a week ago.  I'm not gonna mess with the
scanner while this kernel is building so I expect it will be fine.
I may have been 'crying wolf', so if you want to close this one, be my guest.

Note You need to log in before you can comment on or make changes to this bug.