Bug 57277 - DVDROM treated as IDEFLOPPY when CONFIG_BLK_DEV_IDEFLOPPY=Y
DVDROM treated as IDEFLOPPY when CONFIG_BLK_DEV_IDEFLOPPY=Y
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-08 08:01 EST by Hasbullah bin Pit (sebol)
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-26 11:18:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Detailed story (4.60 KB, text/plain)
2001-12-13 05:46 EST, Hasbullah bin Pit (sebol)
no flags Details
dmesg when the idefloppy=Y (4.56 KB, text/plain)
2001-12-13 05:47 EST, Hasbullah bin Pit (sebol)
no flags Details
dmesg when the config_ideflopy=m (4.80 KB, text/plain)
2001-12-13 05:48 EST, Hasbullah bin Pit (sebol)
no flags Details

  None (edit)
Description Hasbullah bin Pit (sebol) 2001-12-08 08:01:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; ms-MY; rv:0.9.6)
Gecko/20011120

Description of problem:
Using RH 7.2 with Sony DVD-ROM DDU1621. I was successfully install
RH 7.2 using boot disk + CDROM on that DVD Drive.
When i try to mount CDROM on that DVD drive , there are error 
telling that "invalid block devide". After investigating, 
It seem like linux kernel assumed it as "ide-floppy" 
(the ide-floppy 0.9.x error msg appear during dmesg)
The RH 7.2 linux kernel compiled with CONFIG_BLK_DEV_IDEFLOPPY=Y.
when i recompiled as '=m', the kernel treat it as DVDROM drive.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.plug Sony DVD Drive DDU1621
2. boot with kernel 2.4.7 with CONFIG_BLK_DEV_IDEFLOPPY=Y
3.mount cdrom or dvd-rom
	

Actual Results:  cant mount cdrom
ide-floppy.c called

Expected Results:  can mount cdrom.
ide-cdrom.c called

Additional info:
Comment 1 Hasbullah bin Pit (sebol) 2001-12-13 05:46:15 EST
Created attachment 40472 [details]
Detailed story
Comment 2 Hasbullah bin Pit (sebol) 2001-12-13 05:47:50 EST
Created attachment 40473 [details]
dmesg when the idefloppy=Y
Comment 3 Hasbullah bin Pit (sebol) 2001-12-13 05:48:57 EST
Created attachment 40474 [details]
dmesg when the config_ideflopy=m
Comment 4 Arjan van de Ven 2001-12-13 05:55:32 EST
Hmmm one quick question: does it help if you type "depmod -ae" as root ?
Comment 5 Hasbullah bin Pit (sebol) 2001-12-26 11:18:43 EST
erk, Sorry. Its Working... it's a dupe?


[root@localhost RedHat]# cat /proc/ide/drivers 
ide-cdrom version 4.59
ide-floppy version 0.97
ide-disk version 1.10

but why when CONFIG_BLK_DEV_IDEFLOPPY=m , i didnot require to depmod -ae ?
(or i did it automaticcaly during make modeul_install?)

Note You need to log in before you can comment on or make changes to this bug.