This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 572811 - Gateway built-in uvcvideo webcam doesn't work
Gateway built-in uvcvideo webcam doesn't work
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libv4l (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 572824
  Show dependency treegraph
 
Reported: 2010-03-11 23:25 EST by Ira Malinich
Modified: 2010-04-03 04:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 572824 (view as bug list)
Environment:
Last Closed: 2010-04-03 04:50:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The last 40 lines of my /var/log/messages, just as I started Cheese. (3.02 KB, text/plain)
2010-03-11 23:25 EST, Ira Malinich
no flags Details
Results of "lsusb -v". (35.75 KB, application/octet-stream)
2010-03-11 23:27 EST, Ira Malinich
no flags Details

  None (edit)
Description Ira Malinich 2010-03-11 23:25:05 EST
Created attachment 399555 [details]
The last 40 lines of my /var/log/messages, just as I started Cheese.

Description of problem:
Cheese shows only black, but it seems to accept configuration changes (ie. changing resolution, brightness, etc.), implying it at least recognizes the camera.
/var/log/messages shows lots of errors.  (attached)

Version-Release number of selected component (if applicable):
kernel 2.6.33-1.fc13.x86_64
libv4l 0.6.4-2.fc13.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Launch Cheese
  
Actual results:
Only black rectangle.

Expected results:
Video in the Cheese window.
Comment 1 Ira Malinich 2010-03-11 23:27:07 EST
Created attachment 399557 [details]
Results of "lsusb -v".
Comment 2 Hans de Goede 2010-03-12 01:28:51 EST
Thanks for the reports and the logs I've mailed the upstream uvc driver author and asked him to take a look at this.
Comment 3 Laurent Pinchart 2010-03-12 19:27:47 EST
The kernel log doesn't look good. There's a lot of low-level USB errors. If USB hubs start not responding correctly, I don't think the camera can be blamed. It could indeed be bad cabling as hinted by the kernel messages.
Comment 4 Laurent Pinchart 2010-03-12 19:40:10 EST
I might also have spoken too fast, it could be an EHCI bug, triggered by a change in the uvcvideo driver. The problem is being discussed in various places, such as

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/435352?comments=all

A patch has been posted to linux-usb, I don't know if it has already been committed.
Comment 5 Ira Malinich 2010-03-12 19:59:32 EST
It should be noted that this works fine in Fedora 12 with kernel-2.6.32.9-70.fc12.i686 and libv4l-0.6.4-1.fc12.i686.  Tonight I'll try to confirm whether I get any similar kernel messages even though it seems to work.
Comment 6 Hans de Goede 2010-04-01 11:24:17 EDT
(In reply to comment #5)
> It should be noted that this works fine in Fedora 12 with
> kernel-2.6.32.9-70.fc12.i686 and libv4l-0.6.4-1.fc12.i686.  Tonight I'll try to
> confirm whether I get any similar kernel messages even though it seems to work.    

Any luck with checking for similar messages with the F-12 kernel ?
Comment 7 Ira Malinich 2010-04-01 14:52:42 EDT
I haven't had a chance to do any proper testing lately, but I have noted that with a more recent F12 kernel I've started getting the same broken behaviour.  It seems that once I try to use the webcam the USB bus goes bonkers and I lose the ability to attach new devices such as a USB flash drive.  When a device gets plugged in there are no messages in /var/log/messages whatsoever.

I updated to the latest F12 kernel from fedora-updates last night but I haven't tried the camera yet.  I'll try with the new kernel tonight and post the version here.  Is there something else I should be looking at?
Comment 8 Ira Malinich 2010-04-02 15:20:24 EDT
I tested the webcam with all three of the installed F12 kernels, but I couldn't reproduce the problem. So I guess, ignore comment 7.

Installed kernels:
kernel-2.6.32.9-67.fc12.x86_64
kernel-2.6.32.9-70.fc12.x86_64
kernel-2.6.32.10-90.fc12.x86_64
Comment 9 Ira Malinich 2010-04-03 01:39:45 EDT
I've tested with the nightly compose of F13, marked 2010-04-01, and the webcam is working great!  Even all the image properties sliders in Cheese appear to be working.  There aren't even any kernel messages, so I guess this bug can be closed.
Comment 10 Hans de Goede 2010-04-03 04:50:44 EDT
Hi,

Thanks for retesting with the latest F-13, closing.

Regards,

Hans

Note You need to log in before you can comment on or make changes to this bug.