Bug 57307 - printconf 0.3.58 error on module import
printconf 0.3.58 error on module import
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: printconf (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-09 21:40 EST by sean
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-09 21:40:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean 2001-12-09 21:40:24 EST
Description of Problem:

[root@localhost util]# /etc/rc.d/init.d/lpd restart
Stopping lpd:                                              [FAILED]
Starting lpd: Traceback (most recent call last):
  File "/usr/sbin/printconf-backend", line 7, in ?
    import printconf_backend
  File "/usr/share/printconf/util/printconf_backend.py", line 28, in ?
    from printconf_conf import *
  File "/usr/share/printconf/util/printconf_conf.py", line 81, in ?
    from xml.utils import qp_xml
ImportError: No module named utils
No Printers Defined                                        [  OK  ]



Version-Release number of selected component (if applicable):


How Reproducible:
run printconf-gui

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
I've installed python-2.2 , so I could use rpm-4.0.4. 

I can't figure what you're trying to import. The only utils.py on my system
is:

[root@localhost usr]# find . -name "utils.py"
./lib/python1.5/site-packages/xml/parsers/xmlproc/utils.py
[root@localhost usr]# 

So I changed the import statement use it, but that didn't work. Then tried
xmlutils. No luck.

jay
Comment 1 sean 2001-12-14 16:58:24 EST
Now it works.  Maybe because of install of alchemist-1.0.21? Prerequisite?

Note You need to log in before you can comment on or make changes to this bug.