Bug 57309 - ppp on demand hangs on boot
ppp on demand hangs on boot
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-09 22:58 EST by Nick Brown
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-13 05:33:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Brown 2001-12-09 22:58:40 EST
When ppp is set to demand and start on boot, system hangs on boot. ppp
watcher needs to be run as daemon or in background. work around is to hack
the /etc/rc.d/init.d/network script to check if service is ppp and to run
it in background with:

 if [ $i = "ppp0" ]
 then
    action $"Bringing up interface $i: " ./ifup $i boot &
 else
    action $"Bringing up interface $i: " ./ifup $i boot
 fi

a minor pain for me, a major pain when I have to fix my dads box
Comment 1 Thomas Woerner 2004-08-13 05:33:27 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or Fedora
Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.

Note You need to log in before you can comment on or make changes to this bug.