Bug 57322 - abiword SIGSEGV
abiword SIGSEGV
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: abiword (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-10 08:51 EST by Mario Mikocevic
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-11 08:30:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Mikocevic 2001-12-10 08:51:18 EST
Description of Problem:

% AbiWord 
/usr/bin/AbiWord: line 68: 13833 Segmentation fault     
$ABISUITE_LIBEXEC/AbiWord_d "$@"


Version-Release number of selected component (if applicable):

# rpm -qa | grep abiword
abiword-0.9.5-1

How Reproducible:

always

Steps to Reproduce:
1. AbiWord
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
	
[pid 13798] close(4)                    = 0
[pid 13798] munmap(0x40021000, 4096)    = 0
[pid 13798] open("/usr/share/AbiSuite/fonts/hr/fonts.dir", O_RDONLY) = -1
ENOENT (No such file or directory)
[pid 13798] open("/usr/share/AbiSuite/fonts/ISO-8859-2/fonts.dir",
O_RDONLY) = -1 ENOENT (No such file or directory)
[pid 13798] open("/usr/share/AbiSuite/fonts/hr-HR/fonts.dir", O_RDONLY) =
-1 ENOENT (No such file or directory)
[pid 13798] open("/usr/share/AbiSuite/fonts/hr-HR.ISO-8859-2/fonts.dir",
O_RDONLY) = -1 ENOENT (No such file or directory)
[pid 13798] shmget(IPC_PRIVATE, 196608, IPC_CREAT|0x1ff|0666) = 934477826
[pid 13798] shmat(934477826, 0, 0)      = 0x405c2000
[pid 13798] write(3,
"\2\0\4\0\31\0\340\4\1\0\0\0\1\0\0\0=\0\4\0\31\0\340\4\0"..., 1564) = 1564
[pid 13798] read(3, 0xbffff6b0, 32)     = -1 EAGAIN (Resource temporarily
unavailable)
[pid 13798] select(4, [3], NULL, NULL, NULL) = 1 (in [3])
[pid 13798] read(3,
"\22\0/\2\30\0\340\4\30\0\340\4\0\345\251\10\30\0\340\004"..., 32) = 32
[pid 13798] read(3,
"\n\0/\2\30\0\340\4\0\0\0\0000\0\343\0\0\0\2\0\0\0\0\0\30"..., 32) = 32
[pid 13798] read(3,
"\10\0/\2\341\363\375\2605\0\0\0\31\0\340\4\0\0\0\0`\1\376"..., 32) = 32
[pid 13798] read(3,
"\10\1/\2\341\363\375\2605\0\0\0\30\0\340\4\31\0\340\4`"..., 32) = 32
[pid 13798] read(3,
"\22\0000\2\31\0\340\4\31\0\340\4\0\345\251\10\31\0\340"..., 32) = 32
[pid 13798] read(3,
"\21E1\2\31\0\340\4\31\0\340\0048D\5\t\350\347Z\10\0\0\0"..., 32) = 32
[pid 13798] read(3,
"\21\2312\2\30\0\340\4\30\0\340\4\320\37\31@0\231\233\10"..., 32) = 32
[pid 13798] read(3,
"\1\0004\2\0\0\0\0004\202@\0\0\0\0\0\0\0\0\0\1\0\0\0\320"..., 32) = 32
[pid 13798] shmctl(934477826, IPC_RMID, 0) = 0
[pid 13798] brk(0x84f2000)              = 0x84f2000
[pid 13798] --- SIGSEGV (Segmentation fault) ---
<... wait4 resumed> [WIFSIGNALED(s) && WTERMSIG(s) == SIGSEGV], 0, NULL) =
13798
rt_sigprocmask(SIG_BLOCK, [CHLD TTOU], [CHLD], 8) = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [CHLD TTOU], 8) = 0
open("/usr/share/locale/hr_HR/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT
(No such file or directory)
open("/usr/share/locale/hr/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No
such file or directory)
write(2, "/usr/bin/AbiWord: line 68: 13798"..., 90/usr/bin/AbiWord: line
68: 13798 Segmentation fault      $ABISUITE_LIBEXEC/AbiWord_d "$@"
) = 90
rt_sigprocmask(SIG_SETMASK, [CHLD TTOU], NULL, 8) = 0
rt_sigprocmask(SIG_SETMASK, [CHLD], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [CHLD], 8) = 0
rt_sigprocmask(SIG_SETMASK, [CHLD], NULL, 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
--- SIGCHLD (Child exited) ---
Comment 1 Bernhard Rosenkraenzer 2001-12-13 09:33:14 EST
Traced down to your LANG setting - doesn't seem to start up correctly in 
ISO-8859-2 locales.

Temporary workaround: use "LANG=C AbiWord"
Comment 2 Mario Mikocevic 2001-12-17 04:41:57 EST
No bannanas !

% LANG=C
% AbiWord 
/usr/bin/AbiWord: line 68:  7456 Aborted                
$ABISUITE_LIBEXEC/AbiWord_d "$@"

[pid  7487] brk(0x8539000)              = 0x8539000
[pid  7487] --- SIGSEGV (Segmentation fault) ---
[pid  7487] rt_sigaction(SIGSEGV, {0x80e2940, [SEGV], SA_RESTART|0x4000000},
{SIG_DFL}, 8) = 0
[pid  7487] old_mmap(NULL, 2097152, PROT_NONE,
MAP_PRIVATE|MAP_ANONYMOUS|MAP_NORESERVE, -1, 0) = 0x40627000
[pid  7487] munmap(0x40627000, 888832)  = 0
[pid  7487] munmap(0x40800000, 159744)  = 0
[pid  7487] old_mmap(0x40700000, 32768, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x40700000
[pid  7487] --- SIGSEGV (Segmentation fault) ---
[pid  7487] rt_sigaction(SIGSEGV, {0x80e2940, [SEGV], SA_RESTART|0x4000000},
{0x80e2940, [SEGV], SA_RESTART|0x4000000}, 8) = 0
[pid  7487] rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
[pid  7487] getpid()                    = 7487
[pid  7487] kill(7487, SIGABRT)         = 0
[pid  7487] --- SIGABRT (Aborted) ---
<... wait4 resumed> [WIFSIGNALED(s) && WTERMSIG(s) == SIGABRT], 0, NULL) = 7487
rt_sigprocmask(SIG_BLOCK, [CHLD TTOU], [CHLD], 8) = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [CHLD TTOU], 8) = 0
write(2, "/usr/bin/AbiWord: line 68:  7487"..., 90/usr/bin/AbiWord: line 68: 
7487 Aborted                 $ABISUITE_LIBEXEC/AbiWord_d "$@"
) = 90
rt_sigprocmask(SIG_SETMASK, [CHLD TTOU], NULL, 8) = 0
rt_sigprocmask(SIG_SETMASK, [CHLD], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [CHLD], 8) = 0
rt_sigprocmask(SIG_SETMASK, [CHLD], NULL, 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
--- SIGCHLD (Child exited) ---
Comment 3 Bernhard Rosenkraenzer 2002-01-16 10:49:57 EST
It's either

LANG=C ./AbiWord (in one line)

or

export LANG=C
AbiWord
Comment 4 Mario Mikocevic 2002-01-22 08:53:46 EST
Umh, I did just exactly that (ok, I only forgot to mention that I _ALREADY_
have an environment variable LANG).

In short, _neither_ works. Nor `LANG=C AbiWord` nor thingy with export.
I even cd-ed to /usr/bin and ->
% LANG=C ./AbiWord 
./AbiWord: line 68:  5440 Aborted                 $ABISUITE_LIBEXEC/AbiWord_d "$@"
as suggested.

Any more suggestion !?
Comment 5 Toralf 2002-04-11 08:23:46 EDT
I get this, too; with abiword-0.99.2-1 from GNOME hide.

Stack trace:

#0  0x40498ae1 in __kill () from /lib/i686/libc.so.6
#1  0x404988ba in raise (sig=6) at ../sysdeps/posix/raise.c:27
#2  0x4049a062 in abort () at ../sysdeps/generic/abort.c:88
#3  0x080e5c0b in AP_UnixApp::catchSignals ()
#4  0x080e5bb2 in signalWrapper ()
#5  <signal handler called>
#6  0x08225d07 in AD_Document::getFilename ()
#7  0x0822de6f in XAP_Frame::backup ()
#8  0x080e5c3a in AP_UnixApp::catchSignals ()
#9  0x080e5bb2 in signalWrapper ()
#10 <signal handler called>
#11 0x404efc18 in strcmp () from /lib/i686/libc.so.6
#12 0x0821e406 in compareFontNames ()
#13 0x08132bf2 in void __introsort_loop<void **, void *, int, int (*)> ()
#14 0x0813275b in UT_Vector::qsort ()
#15 0x0821e461 in XAP_UnixFontManager::getAllFonts ()
#16 0x08260812 in AP_UnixToolbar_FontCombo::populate ()
#17 0x081250e3 in EV_UnixToolbar::synthesize ()
#18 0x0822d868 in XAP_Frame::_createToolbars ()
#19 0x0821a747 in XAP_UnixFrame::_createTopLevelWindow ()
#20 0x080e6c00 in AP_UnixFrame::initialize ()
#21 0x080e3643 in AP_UnixApp::newFrame ()
#22 0x080e5a72 in AP_UnixApp::parseCommandLine ()
#23 0x080e5288 in AP_UnixApp::main ()
#24 0x080e2ec9 in main ()
#25 0x40486627 in __libc_start_main (main=0x80e2e64 <main>, argc=1,
ubp_av=0xbfffed24, init=0x80dfecc <_init>, fini=0x835c6a0 <_fini>,
rtld_fini=0x4000dcd4 <_dl_fini>, stack_end=0xbfffed1c) at
../sysdeps/generic/libc-start.c:129
Comment 6 Toralf 2002-04-11 08:30:08 EDT
Note that AbiWord wrapper's attempt to modify font path fails, but I have
% xset -q
[ ... ]
Font Path:
  unix/:7100
[ ... ]

and

% chkfontpath
Current directories in font path:
1: /usr/X11R6/lib/X11/fonts/misc:unscaled
2: /usr/X11R6/lib/X11/fonts/75dpi:unscaled
3: /usr/X11R6/lib/X11/fonts/100dpi:unscaled
4: /usr/X11R6/lib/X11/fonts/misc
5: /usr/X11R6/lib/X11/fonts/Type1
6: /usr/X11R6/lib/X11/fonts/Speedo
7: /usr/X11R6/lib/X11/fonts/CID
8: /usr/X11R6/lib/X11/fonts/75dpi
9: /usr/X11R6/lib/X11/fonts/100dpi
10: /usr/share/fonts/default/Type1
11: /usr/share/AbiSuite/fonts
Comment 7 Mario Mikocevic 2002-04-11 08:40:03 EDT
Well, it's fixed in 0.99.3 and since Rawhide just
published 0.99.4 I'm changing resolution.

Note You need to log in before you can comment on or make changes to this bug.