Bug 573310 - [abrt] crash in guake-0.4.1-2.fc12: guake.py:433:configure_terminal:TypeError: Vte.Terminal.set_word_chars() argument 1 must be string, not None
Summary: [abrt] crash in guake-0.4.1-2.fc12: guake.py:433:configure_terminal:TypeError...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: guake
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Pierre-YvesChibon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:5e321f9d
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-14 01:57 UTC by Rabin
Modified: 2010-05-19 19:20 UTC (History)
3 users (show)

Fixed In Version: guake-0.4.1-3.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-19 19:09:14 UTC


Attachments (Terms of Use)
File: backtrace (1007 bytes, text/plain)
2010-03-14 01:57 UTC, Rabin
no flags Details

Description Rabin 2010-03-14 01:57:54 UTC
abrt 1.0.8 detected a crash.

architecture: i686
cmdline: guake -OO /usr/lib/guake/guake.py
component: guake
executable: /usr/lib/guake/guake.py
kernel: 2.6.31.12-174.2.19.fc12.i686.PAE
package: guake-0.4.1-2.fc12
reason: guake.py:433:configure_terminal:TypeError: Vte.Terminal.set_word_chars() argument 1 must be string, not None
release: Fedora release 12 (Constantine)

backtrace
-----
guake.py:433:configure_terminal:TypeError: Vte.Terminal.set_word_chars() argument 1 must be string, not None

Traceback (most recent call last):
  File "/usr/lib/guake/guake.py", line 1289, in <module>
    if not main():
  File "/usr/lib/guake/guake.py", line 1232, in main
    instance = Guake()
  File "/usr/lib/guake/guake.py", line 595, in __init__
    self.add_tab()
  File "/usr/lib/guake/guake.py", line 1057, in add_tab
    box = GuakeTerminalBox()
  File "/usr/lib/guake/guake.py", line 483, in __init__
    self.terminal = GuakeTerminal()
  File "/usr/lib/guake/guake.py", line 423, in __init__
    self.configure_terminal()
  File "/usr/lib/guake/guake.py", line 433, in configure_terminal
    self.set_word_chars(word_chars)
TypeError: Vte.Terminal.set_word_chars() argument 1 must be string, not None

Local variables in innermost frame:
self: <GuakeTerminal object at 0x8c890cc (VteTerminal at 0x8cf5000)>
client: <gconf.Client object at 0x8c85f7c (GConfClient at 0x8bd66f0)>
word_chars: None

comment
-----
Just try to run it.

How to reproduce
-----
1. trying to run just after installation cuse the application to crash
2.
3.

Comment 1 Rabin 2010-03-14 01:57:57 UTC
Created attachment 399932 [details]
File: backtrace

Comment 2 Spencer Tom Tafadzwa Chirume 2010-03-22 20:29:07 UTC

How to reproduce
-----
1. Startting the guake from the start menu,
2. abrt icon shows up after a bit in the notification area,
3. Wait for the abrt GUI to kick in after a moment or two.

Comment 3 Pierre-YvesChibon 2010-03-24 08:43:56 UTC
Could you reproduce it ?

Comment 4 Spencer Tom Tafadzwa Chirume 2010-03-27 00:06:01 UTC

How to reproduce
-----
1. Launching Gauke 


Comment
-----
Same problem as with previous posts only now on 64 bit the crash bug is apparent.

Comment 5 Pierre-YvesChibon 2010-03-27 09:31:10 UTC
Did you try to reinstall it ?
You can reproduce it all the time ?

Can you check if the gconf scheme is installed ?

Sorry for asking these questions but I cannot reproduce it here.

Comment 6 Konstantinos Antonakoglou 2010-05-04 19:25:27 UTC
Package: guake-0.4.1-2.fc12
Architecture: x86_64
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1.install guake
2.run it through terminal or applications menu

Comment 7 Fedora Update System 2010-05-07 22:44:55 UTC
guake-0.4.1-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/guake-0.4.1-3.fc12

Comment 8 Fedora Update System 2010-05-07 22:45:16 UTC
guake-0.4.1-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/guake-0.4.1-3.fc13

Comment 9 Fedora Update System 2010-05-07 22:45:38 UTC
guake-0.4.1-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/guake-0.4.1-3.fc11

Comment 10 Fedora Update System 2010-05-08 13:47:41 UTC
guake-0.4.1-4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/guake-0.4.1-4.fc13

Comment 11 Fedora Update System 2010-05-08 16:09:31 UTC
guake-0.4.1-4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update guake'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/guake-0.4.1-4.fc13

Comment 12 Fedora Update System 2010-05-10 16:57:24 UTC
guake-0.4.1-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update guake'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/guake-0.4.1-3.fc11

Comment 13 Fedora Update System 2010-05-10 17:09:43 UTC
guake-0.4.1-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update guake'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/guake-0.4.1-3.fc12

Comment 14 Fedora Update System 2010-05-19 19:08:53 UTC
guake-0.4.1-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2010-05-19 19:10:42 UTC
guake-0.4.1-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2010-05-19 19:19:40 UTC
guake-0.4.1-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.