Bug 57344 - RFE: display of long user names in ls(1)
RFE: display of long user names in ls(1)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: fileutils (Show other bugs)
7.2
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-10 12:29 EST by Steve Bonneville
Modified: 2007-03-26 23:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-10 12:29:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Bonneville 2001-12-10 12:29:11 EST
Right now, if you use `ls -l` to display files that are owned by a user
with a username longer than 8 characters, the displayed name is truncated
to 8 characters.  There's no indication the name has been truncated and/or
no way to display the full username.

Files owned by two users with similar names can be distinguished, but to
tell whether a file is owned by "longname" or "longnameuser", you'd have to
do an `ls -ln` and compare UIDs (or GIDs, since the same story is true for
groups).

It'd be a nice enhancement if ls could indicate if a long name was
truncated, or display long names if necessary (even if it involved a
special command-line option).
Comment 1 Bernhard Rosenkraenzer 2002-01-17 11:45:26 EST
[root@spock root]# adduser microsoftsucks
[root@spock root]# touch foo
[root@spock root]# chown microsoftsucks foo
[root@spock root]# ls -l foo
-rw-r--r--    1 microsoftsucks root            0 Jan 17 17:37 foo
[root@spock root]# chgrp microsoftsucks foo
[root@spock root]# ls -l foo
-rw-r--r--    1 microsoftsucks microsoftsucks        0 Jan 17 17:37 foo
[root@spock root]# rpm -q fileutils
fileutils-4.1.4-1

Note You need to log in before you can comment on or make changes to this bug.