Bug 57347 - Kernels fail to build with latest (rawhide) binutils
Summary: Kernels fail to build with latest (rawhide) binutils
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: binutils   
(Show other bugs)
Version: 1.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-10 18:00 UTC by Need Real Name
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-13 09:03:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-12-10 18:00:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011113

Description of problem:
Kernels 2.4.9-16/17.3, 2.4.16-0.4/0.6 fails to build with
binutils-2.11.92.0.12-2. Builds with binutils-2.11.92.0.7-2

Version-Release number of selected component (if applicable):
see above

How reproducible:
Always

Steps to Reproduce:
1.Compile from source
2.
3.
	

Actual Results:  Segmentation fault at kallsyms pass 1

Additional info:

Following is the output from building two kernels (similar for other kernels):
kernel-2.4.9-16:(gcc-2.96-101)
gcc -D__KERNEL__ -I/usr/src/redhat/BUILD/kernel-2.4.9/linux/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fomit-frame-pointer
-fno-strict-aliasing -fno-common -Wno-unused -pipe
-mpreferred-stack-boundary=2 -march=i686  -E -D__GENKSYMS__ i386_ksyms.c
| /sbin/genksyms  -k 2.4.9 >
/usr/src/redhat/BUILD/kernel-2.4.9/linux/include/linux/modules/i386_ksyms.ver.tmp
mv
/usr/src/redhat/BUILD/kernel-2.4.9/linux/include/linux/modules/i386_ksyms.ver.tmp
/usr/src/redhat/BUILD/kernel-2.4.9/linux/include/linux/modules/i386_ksyms.ver
md5sum: WARNING: 2 of 13 computed checksums did NOT match
/usr/src/redhat/BUILD/kernel-2.4.9/linux/include/linux/modversions.h was
updated
+ make -s include/linux/version.h
+ echo BUILDING A KERNEL FOR debug i686...
BUILDING A KERNEL FOR debug i686...
+ make -s -j 1 bzImage
init/main.c: In function `start_kernel':
init/main.c:740: warning: implicit declaration of function `kiobuf_setup'
fork.c:621:2: warning: #warning Do something about KSTACK here ...
traps.c: In function `callout_dbfunc':
traps.c:449: warning: int format, dbfunc_t arg (arg 3)
dmi_scan.c: In function `broken_ps2_resume':
dmi_scan.c:402: warning: assignment from incompatible pointer type
{standard input}: Assembler messages:
{standard input}:1069: Warning: indirect lcall without `*'
{standard input}:1153: Warning: indirect lcall without `*'
{standard input}:1239: Warning: indirect lcall without `*'
{standard input}:1313: Warning: indirect lcall without `*'
{standard input}:1324: Warning: indirect lcall without `*'
{standard input}:1335: Warning: indirect lcall without `*'
{standard input}:1410: Warning: indirect lcall without `*'
{standard input}:1421: Warning: indirect lcall without `*'
{standard input}:1432: Warning: indirect lcall without `*'
{standard input}:1912: Warning: indirect lcall without `*'
{standard input}:2010: Warning: indirect lcall without `*'
{standard input}: Assembler messages:
{standard input}:210: Warning: indirect lcall without `*'
{standard input}:304: Warning: indirect lcall without `*'
acpitable.c:165:10: warning: #warning FIXME __va works for 1 page only it
seems!!
kallsyms pass 1
make[1]: *** [kallsyms] Segmentation fault
make: *** [vmlinux] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.57204 (%build)

kernel-2.4.16-0.6:(gcc-3.1.0-0.10)
kallsyms pass 1
make[1]: *** [kallsyms] Segmentation fault
make: *** [vmlinux] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.23137 (%build)

#>rpm -q modutils binutils sh-utils bash patch gnupg
modutils-2.4.12-1
binutils-2.11.92.0.12-2
sh-utils-2.0.11-7
bash-2.05a-1
patch-2.5.4-10
gnupg-1.0.6-3

Comment 1 Arjan van de Ven 2001-12-13 09:02:59 UTC
binutils bug

Comment 2 Jakub Jelinek 2001-12-18 15:06:06 UTC
Should be fixed in binutils-2.11.92.0.12-4.

Comment 3 orders1 2001-12-19 17:20:03 UTC
binutils-2.11.92.0.12-4 does not fix the problem
I am using gcc-3.1-0.10

Comment 4 Jakub Jelinek 2001-12-19 19:56:35 UTC
What kind of errors do you get?

Comment 5 Need Real Name 2001-12-19 22:30:30 UTC
For me kernel-2.4.16-0.13 builds with binutils-2.11.92.0.12-4 and it boots!!
Yippee ;-) This is when compiled with gcc-2.96.101.9. When compiled with
gcc-3.1-0.10 it doesn't boot.

Same problems for kernel-2.4.9-x. They build, but does not boot, when compiled
with gcc-3.1. Latest one built is 2.4.9-18, with a small patch applied, see Bug
57632. It does not boot, hangs at the same place as before. Haven't tried to
compile with gcc-2.96 yet (compile time is 7 hours 30 minutes!!)

Comment 6 orders1 2001-12-22 00:17:07 UTC
Errors not due to ld. Please ignore my previous comment.


Note You need to log in before you can comment on or make changes to this bug.