Bug 57380 - Kernel panic: No init found. Try passing init= option for kernel -> MEMORY PROBLEM WITH 4GB
Kernel panic: No init found. Try passing init= option for kernel -> MEMORY ...
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-11 04:29 EST by Klaus Lehnen
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-05 17:03:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Klaus Lehnen 2001-12-11 04:29:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [de] (X11; U; Linux 2.4.2-2 i686; Nav)

Description of problem:
After upgrading to Errata Kernel 2.4.9-12enterprise the system doesn't boot
from root device. 
 
The boot message: 
Mounting root device 
mount: error 6 mounting ext2 
pivotroot: pivot_root (/sysroot,/sysroot/initrd) failed:2  
Freeing unused kernel memory: 200k 
Kernel panic: No init found. Try passing init= option to kernel. 


Version-Release number of selected component (if applicable):
filesystem-2.1.0-2.1                          Tue 27 Nov 2001 05:24:27 PM
CET
mkinitrd-3.2.6-1                              Tue 27 Nov 2001 05:21:09 PM
CET
mount-2.11b-3                                 Tue 27 Nov 2001 05:20:13 PM
CET
kernel-enterprise-2.4.2-2                     Tue 27 Nov 2001 01:10:58 PM
CET
kernel-enterprise-2.4.9-12                    Mon 26 Nov 2001 09:05:04 PM
CET
modutils-2.4.6-4                              Mon 26 Nov 2001 09:04:25 PM
CET
e2fsprogs-devel-1.23-1.7.1                    Mon 26 Nov 2001 08:49:42 PM
CET
e2fsprogs-1.23-1.7.1                          Mon 26 Nov 2001 08:49:26 PM
CET


How reproducible:
Always

Steps to Reproduce:
1. Upgrade to Errata Kernel 2.4.9-12enterprise, filesystem-2.1.0-2.1, 
   mkinitrd-3.2.6-1, mount-2.11b-3, modutils-2.4.6-4,        
   e2fsprogs-1.23-1.7.1e2fsprogs-1.23-1.7.1 
2. cd /boot 
 
3. mkinitrd /boot/initrd-2.4.9-12enterprise.img \ 
   vmlinuz-2.4.2-2enterprise 
 
4. edit /etc/lilo.conf and add thr following entry: 
 
  image=/boot/vmlinuz-2.4.9-12enterprise 
        label=linux.sap 
        initrd=/boot/initrd-2.4.9-12enterprise.img 
        read-only 
        root=/dev/cciss/c0d0p5 
    
 


Actual Results:  kernel panic: 
============= 
Mounting root device 
mount: error 6 mounting ext2 
pivotroot: pivot_root (/sysroot,/sysroot/initrd) failed:2  
Freeing unused kernel memory: 200k 
Kernel panic: No init found. Try passing init= option to kernel. 


Expected Results:  Normal boot with the new kernel.

Additional info:

The maschine is a Compaq DL380 G2 with a 5304 Raid Controller. 
I have testet the kernel with a normal PC. the result is the same.
The PC also doesn't boot.

The /etc/fstab: 
/dev/cciss/c0d0p5       /                       ext2    defaults        1 1 
/dev/cciss/c0d0p1       /boot                   ext2    defaults        1 2 
/dev/fd0                /mnt/floppy             auto    noauto,owner    0 0 
/dev/cciss/c0d4p1       /oracle                 ext2    defaults        1 2 
/dev/cciss/c0d1p7       /oracle/E32/mirrlogA    ext2    defaults        1 2 
/dev/cciss/c0d0p6       /oracle/E32/mirrlogB    ext2    defaults        1 2 
/dev/cciss/c0d0p7       /oracle/E32/origlogA    ext2    defaults        1 2 
/dev/cciss/c0d1p6       /oracle/E32/origlogB    ext2    defaults        1 2 
/dev/cciss/c0d2p1       /oracle/E32/saparch     ext2    defaults        1 2 
/dev/cciss/c0d3p1       /oracle/K32/mirrlogA    ext2    defaults        1 2 
/dev/cciss/c0d2p7       /oracle/K32/mirrlogB    ext2    defaults        1 2 
/dev/cciss/c0d2p6       /oracle/K32/origlogA    ext2    defaults        1 2 
/dev/cciss/c0d3p5       /oracle/K32/origlogB    ext2    defaults        1 2 
/dev/cciss/c0d1p1       /oracle/K32/saparch     ext2    defaults        1 2 
none                    /proc                   proc    defaults        0 0 
none                    /dev/pts                devpts  gid=5,mode=620  0 0 
/dev/cciss/c0d1p5       swap                    swap    defaults        0 0 
/dev/cciss/c0d2p5       swap                    swap    defaults        0 0 
/dev/cdrom              /mnt/cdrom              iso9660
noauto,owner,kudzu,r
Comment 1 Arjan van de Ven 2001-12-11 15:55:47 EST
Does this machine have a 450NX chipset ? If so, could you please try the kernel 2.4.9-17.6
from http://people.redhat.com/arjanv/testkernels
that kernel has a fix for a bug in the compaq 450nx chipset handling.
(if it complains about too old modutils you can ignore that error with --nodeps if needed)
Comment 2 Klaus Lehnen 2001-12-12 08:27:07 EST
I have this Kernel installed on the CPQ DL380 G2.
(incl. the entry in /etc/lilo.conf + lilo -v)

The result ist the same.

I think it is a problem with /mkinitrd filesystem in the / filesystem.
Because the size of the / filesystem is 14 GB.
We have an special /boot with 50MB, but this new /mkinitrd in in the /.

Is it possible that the kernel can not change the root ?
Comment 3 Arjan van de Ven 2001-12-12 10:25:16 EST
 /mkinitrd or /initrd ? (it SHOULD be the later)
Comment 4 Klaus Lehnen 2001-12-12 10:54:30 EST
it is /initrd.

here is the output of the ls command:
[root@rh05 /]# ls -ld initrd
drwxr-xr-x    8 root     root         1024 Nov 26 14:52 initrd
Comment 5 Klaus Lehnen 2001-12-12 11:11:08 EST
is this correct ?

[root@rh05 /initrd]# ls -l
total 7
drwxr-xr-x    2 root     root         1024 Nov 26 14:52 bin
drwxr-xr-x    2 root     root         1024 Nov 26 14:52 dev
drwxr-xr-x    2 root     root         1024 Nov 26 14:52 etc
drwxr-xr-x    2 root     root         1024 Nov 26 14:52 lib
-rwxr-xr-x    1 root     root          168 Nov 26 14:52 linuxrc
drwxr-xr-x    2 root     root         1024 Nov 26 14:52 loopfs
drwxr-xr-x    2 root     root         1024 Nov 26 14:52 sbin
[root@rh05 /initrd]# ls sbin
bin  modprobe
[root@rh05 /initrd]# cd sbin
[root@rh05 sbin]# ls
bin  modprobe
[root@rh05 sbin]# cd bin
bash: cd: bin: Too many levels of symbolic links
[root@rh05 sbin]# ls -l
total 0
lrwxrwxrwx    1 root     root            3 Nov 26 14:52 bin -> bin
lrwxrwxrwx    1 root     root            9 Nov 26 14:52 modprobe -> /bin/nash
[root@rh05 sbin]# pwd
/initrd/sbin
[root@rh05 sbin]# ls /bin/nash
ls: /bin/nash: No such file or directory
Comment 6 Michael K. Johnson 2001-12-17 14:33:06 EST
Why is the initrd in / instead of in /boot?  (The first part of the
report says that it is in /boot, so I'm really confused here.)
Second, I think that the bin -> bin symlink is the problem you are
seeing here, which would make this a bug in mkinitrd, not in the
kernel.  I'm re-assigning this to mkinitrd.
Comment 7 Klaus Lehnen 2001-12-18 04:46:45 EST
One of the problem i have, is follow:

The Compaq DL380 G2 has two RAID Controllers ( 5i and 5304).
Kernel 2.4.2 use the Compaq CISS Driver (v 2.4.2).

The result is:

Smart Array 5i   will be /dev/cciss/c1xxxx
Smart Array 5304 will be /dev/cciss/c0xxxx

After upgrading to kernel to 2.4.9-12 -13 or -17 
a newer Compaq CCISS Driver (2.4.5 or later is used) 
the controller order will be the follows:

Smart Array 5i   will be /dev/cciss/c0xxxx
Smart Array 5304 will be /dev/cciss/c1xxxx

THE RESULT IS KERNEL PANIC !!!

i don't use the 5i controller.
i have the 5i controller deactive.

So the Smart Array 5304 will be /dev/cciss/c0xxxx
But i have many other errors while init works the runlvel 
(USB and so on).
I think i need a complete testet packet for the updatet kernel.

Which software MUST be updatet an RH71 for use with the kernel 2.4.9-17.6 ?






Comment 8 Klaus Lehnen 2001-12-20 04:16:57 EST
Sorry, there is mistake in Steps to Reproduce point 3.
The commands that i have used for mkinitrd:

[root@rh05 /root]# history | grep "mkinitrd init"
  151  mkinitrd initrd-2.4.9-12enterprise.img vmlinuz-2.4.9-12enterprise
  465  mkinitrd initrd-2.4.9-17.6enterprise.img 2.4.9-17.6enterprise


Comment 9 Klaus Lehnen 2002-01-08 07:36:21 EST
The startup report of the system with kernel: vmlinuz-2.4.9-17.6enterprise
================================================================================
latest ok-message is:
=====================
Remounting root filesystem                                         

the errors:
===========
/etc/rc.sysinit: /bin/rm cannot execute binary file
/etc/sysconfig/harddisks cannot execute binary file
/bin/cat cannot execute binary file
/bin/rm cannot execute binary file
/bin/uname cannot execute binary file
/bin/cat cannot execute binary file
Finding module dependencies: /sbin/depmod: /sbin/depmod cannot execute binary 
file
/sbin/mingetty: /sbin/mingetty: cannot execute binary file

following messages occures after this:
======================================
INIT: Id "1" respawning too fast: disabled for 5 minutes
INIT: Id "2" respawning too fast: disabled for 5 minutes
INIT: Id "3" respawning too fast: disabled for 5 minutes
INIT: Id "4" respawning too fast: disabled for 5 minutes
INIT: Id "5" respawning too fast: disabled for 5 minutes
INIT: Id "6" respawning too fast: disabled for 5 minutes

Comment 10 Klaus Lehnen 2002-01-09 11:31:07 EST
The new problem is fixed by reducing the memory=3500M

The COMPAQ DL380 G2 doesn't start with the kernel 2.4.9-17.6enterprise without 
memory limitation (2.4.2-2 works fine !)
The 2.4.9-17.6enterprise works fine with the limitation of 3500M.

But this COMPAQ DL380 G2 has 6GB memory (this not so nice) 
Comment 11 Klaus Lehnen 2002-01-11 09:45:43 EST
i have made new tests with kernel memory limitation:

3800M works fine
3900M results kernel panic !
Comment 12 Matt Wilson 2002-02-05 17:03:15 EST
LILO does not do proper e820 memory map hole detection.  GRUB should properly
navigate around memory holes.  Until GRUB is an option you will need to pass the
mem= limitation to keep LILO from loading the initrd in a reserved section of
memory.
Comment 13 Klaus Lehnen 2002-02-06 02:49:59 EST
With the new Kernel 2.4.9-21enterprise the problem is complete fixed.
This Kernel works fine with 6GB Memory! 
It was not a problem of LILO.

Note You need to log in before you can comment on or make changes to this bug.