Bug 57394 - gcc fails for qt applications
gcc fails for qt applications
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-11 11:16 EST by Sammy
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-11 11:17:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
c++ program that fails for configure (433 bytes, text/plain)
2001-12-11 11:17 EST, Sammy
no flags Details

  None (edit)
Description Sammy 2001-12-11 11:16:25 EST
Description of Problem:

Since I updated to gcc-3.1-0.10 from rawhide I cannot compile
and of my qt dependent applications as the configure scripts fail
to run the little c++ program for testing. Everything compiled fine
with gcc-2.96 with the same qt packages. The error I get is:

configure:5393: checking for Qt
tried NO
configure:5552: rm -rf SunWS_cache; g++ -o conftest -O2 -fno-exceptions 
-fno-check-new -O2 -march=i386 -mcpu=i686 -DNDEBUG -DNO_DEBUG 
-fno-check-new -I/usr/lib/qt-2.3.1/include -I/usr/X11R6/include   
-L/usr/lib/qt-2.3.1/lib -L/usr/X11R6/lib  conftest.C  -lqt -lpng -lz -lm -ljpeg  
-lXext -lX11 -lSM -lICE  1>&5
/tmp/ccSoVh0l.o: In function `main':
/tmp/ccSoVh0l.o(.text+0x40): undefined reference to `QString::shared_null'
/tmp/ccSoVh0l.o(.text+0x8a): undefined reference to 
`QIconView::QIconView(QWidget*, char const*, unsigned)'
/tmp/ccSoVh0l.o(.text+0x9a): undefined reference to 
`QIconView::setWordWrapIconText(bool)'
/tmp/ccSoVh0l.o(.text+0x9f): undefined reference to `QString::shared_null'
/tmp/ccSoVh0l.o(.text+0xc3): undefined reference to `QString::setLatin1(char 
const*, int)'
/tmp/ccSoVh0l.o(.text+0xde): undefined reference to `QString::shared_null'
/tmp/ccSoVh0l.o(.text+0xe8): undefined reference to `QStringData::deleteSelf()'
/tmp/ccSoVh0l.o(.text+0xf0): undefined reference to `QIconView::~QIconView()'
/tmp/ccSoVh0l.o(.text+0x104): undefined reference to `QString::shared_null'
/tmp/ccSoVh0l.o(.text+0x111): undefined reference to 
`QString::makeSharedNull()'/tmp/ccSoVh0l.o(.text+0x118): undefined reference 
to `QString::makeSharedNull()'


The qt libs and include files are in the above location and worked before. Is
this because the libraries are binary incompatible? I have tried recompiling
qt-2.3.1-5 but that failed in designer with the error:

/usr/src/redhat/BUILD/qt-2.3.1/bin/uic listboxeditor.ui -o ./listboxeditor.h
/usr/src/redhat/BUILD/qt-2.3.1/bin/uic: relocation error: 
/usr/src/redhat/BUILD/qt-2.3.1/bin/uic: undefined symbol: _ZN5QChar4nullE
make[5]: *** [listboxeditor.h] Error 127

which also compiled just a few days ago with 2.96. I am attaching the
conftest.C program that fails for configure in case it helps.
Comment 1 Sammy 2001-12-11 11:17:24 EST
Created attachment 40347 [details]
c++ program that fails for configure
Comment 2 Jakub Jelinek 2001-12-11 11:20:45 EST
The compilers are of course totally binary incompatible.
qt build fails probably because it tries to run newly compiled uic program
against 2.96-RH compiled libqt.
I'd say, if you want things just work, downgrade gcc back to 2.96-RH.
Comment 3 Sammy 2001-12-11 13:08:20 EST
I am using the compatibility packages for gcc-2.96 and that way everything
is working now BUT gcc-3.1 is required by other stuff in rawhide so I need
to have it.

How about if I compile qt with 3.1? I guess I'll have to recompile everything
that depends on it as well, right?

Note You need to log in before you can comment on or make changes to this bug.