Bug 57404 - elatex fails on hebrew documents
elatex fails on hebrew documents
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
http://www.cs.huji.ac.il/system/patch...
:
: 65166 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-11 13:09 EST by Tomas Winkler
Modified: 2013-07-02 18:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-04 03:29:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to teTeX-texmf-gg-1.0.3.tar.bz2 (356 bytes, patch)
2001-12-11 13:12 EST, Tomas Winkler
no flags Details | Diff
a tex file generated by lyx (544 bytes, text/plain)
2001-12-12 06:32 EST, Tomas Winkler
no flags Details

  None (edit)
Description Tomas Winkler 2001-12-11 13:09:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
elatex fials on hebrew tex docmuments becacuse of wrong line (70) in
texmf/tex/generic/babel/lheenc.def 
$</LHEenc>


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.myfile.tex
2.elatex myfile.tex

	

Actual Results:  ee the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...                                              
                                                  
l.73 $
      </LHEenc>



Additional info:
The patch
--- texmf/tex/generic/babel/lheenc.def  Tue Dec 11 18:15:32 2001
+++ texmf/tex-huji/generic/babel/lheenc.def     Tue Dec 11 18:17:27 2001
@@ -70,7 +70,6 @@
 \DeclareTextSymbol{\tav}{LHE}{122}
 \let\org@sin=\sin
 \def\sin{\ifmmode\org@sin\else\shin\fi}
-$</LHEenc>
 %%
 %% \CharacterTable
 %%  {Upper-case    \A\B\C\D\E\F\G\H\I\J\K\L\M\N\O\P\Q\R\S\T\U\V\W\X\Y\Z
Comment 1 Tomas Winkler 2001-12-11 13:12:55 EST
Created attachment 40367 [details]
patch to teTeX-texmf-gg-1.0.3.tar.bz2
Comment 2 Tim Waugh 2001-12-12 05:03:06 EST
Please attach a hebrew document for regression testing.  Thanks.
Comment 3 Tomas Winkler 2001-12-12 06:32:26 EST
Created attachment 40407 [details]
a tex file generated by lyx
Comment 4 Tomas Winkler 2001-12-12 06:42:57 EST
Removing the line from the lheenc.def is not enough. To make it work I had to
also replace most of the hebrew font definiton files (*.fd) under
/usr/share/texmf/tex/generic/babel/ at least I took them from mandrake 
tetex-latex-heb-1.0.2.rpm 
rpm -qip 
Name        : tetex-latex-heb              Relocations: (not relocateable)
Version     : 1.0.2                             Vendor: MandrakeSoft
Release     : 2                             Build Date: Wed 28 Feb 2001 12:58:26
 AM IST
Install date: (not installed)               Build Host: canada1.technion.ac.il
Group       : Applications/Publishing       Source RPM: tetex-latex-heb-1.0.2-2.
src.rpm
Size        : 2201049                          License: distributable
Packager    : Tzafrir Cohen <tzafrir@technion.ac.il>
URL         : http://www.dsg.technion.ac.il/heblatex/
Summary     : Files for processing Hebrew LaTeX documents
Description :
Comment 5 Jindrich Novy 2005-05-04 03:29:23 EDT
Please file a new bug for this if the problem still persists in teTeX-3.0.

Thanks.
Comment 6 Jindrich Novy 2005-05-04 06:40:52 EDT
*** Bug 65166 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.