Bug 574153 - konsole: ugly Russian font by default
konsole: ugly Russian font by default
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-16 14:27 EDT by Alexey Dobriyan
Modified: 2011-06-14 10:12 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-14 10:12:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Konsole screenshot (35.19 KB, image/png)
2010-03-16 14:27 EDT, Alexey Dobriyan
no flags Details
screenshot (18.49 KB, image/jpeg)
2011-06-14 10:12 EDT, Ngo Than
no flags Details

  None (edit)
Description Alexey Dobriyan 2010-03-16 14:27:48 EDT
Created attachment 400529 [details]
Konsole screenshot

There is long standing ugliness by default.
Default Konsole font (Monospace, size 10):

Russian symbols are 1 px smaller that English.
When typing Russian symbols, cursor moves 1 px more to the right than needed.
Consequently, there can be very visible gap if several symbols are typed.

It's hard to show on screenshot, but after typing first Russian symbol,
the whole line moves 1 px down, and it's also very noticeable.

How reproducible: Always
Comment 1 Bug Zapper 2010-07-30 07:05:52 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Ngo Than 2011-06-14 10:12:23 EDT
Created attachment 504681 [details]
screenshot

i cannot reproduce this issue with latest qt-4.7.2 in f14-update, see my screenshot made on my test machine.

please reopen the bug if you still can reproduce it. thanks

Note You need to log in before you can comment on or make changes to this bug.