Bug 5745 - Kernel upgrades fail
Kernel upgrades fail
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-08 19:08 EDT by jvincent
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-16 11:11:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jvincent 1999-10-08 19:08:14 EDT
I recently upgraded one of my nameservers that was running
5.2 and a 2.2.12 kernel to 6.1. After installing I went to
recompile the kernel to strip out the stuff I didn't need. I
then ran linuxconf to install the new kernel. The kernel was
made with make dep;make boot(It's monolithic). The size of
the compiled kernel was around 400k. Linuxconf refused to
install the kernel citing /dev/hda1 as not valid although
that is where the current kernel root is. I went to manually
install the kernel and lilo kept complaining that the image
was too big. The kernel built fine and I've tried several
times yet lilo still refuses to install the new kernel. I
downloaded a src tarball of 2.2.12 from one of the
kernel.org mirrors (I had problems in the past with the
source that shipped with an earlier version and thought that
my be the issue.) Unfortunatly lilo still refused. I've only
upgraded one other box to 6.1 and that was from 6.0 and not
5.2 I plan on taking some time this weekend and recompiling
on my personal machine to see if the same problem occurs. At
this point I am thinking it is a problem with lilo.
Comment 1 Bill Nottingham 1999-10-08 19:45:59 EDT
Try doing 'make bzImage' instead of 'make zImage'.

------- Additional Comments From   10/08/99 21:23 -------
As an update it is failing with the same probs at home on a 6.0 to 6.1
upgrade. I haven't tried this on a machine with a fresh install. I
will find a machine to try it as well
Comment 2 jvincent 1999-10-08 21:26:59 EDT
I will try making the image that way. Would that be causing linuxconf
to report that my root partition was invalid? At home it says
/dev/sda5 is not valid and at the office it says /dev/hda1
Comment 3 jvincent 1999-10-08 21:35:59 EDT
make bzImage worked when I manually set up /etc/lilo.conf and ran
lilo. Linuxconf still complained that /dev/sda5 wasn't a valid
partition as well as /dev/hda1 on the nameserver machine.
Comment 4 Cristian Gafton 2000-01-04 17:27:59 EST
Assigned to dledford
Comment 5 Bernhard Rosenkraenzer 2000-02-16 11:11:59 EST
The initial bug is caused by zImage instead of bzImage.
The linuxconf issue might be a real bug though - assigning to the owner of
linuxconf.
Comment 6 Brent Fox 2002-06-05 12:04:58 EDT
Closing because we don't ship linuxconf anymore.

Note You need to log in before you can comment on or make changes to this bug.