Bug 57450 - (USB KEYBOARD)dead keyboard after kernel upgrade
(USB KEYBOARD)dead keyboard after kernel upgrade
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
?
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-12 14:56 EST by David Korenberg
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Korenberg 2001-12-12 14:56:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
Please refer to Service Request #195322 for info.
I've upgrade my 2.4.2-2 kernel to version 2.4.9-12 using Update Agent
2.5.4-1.
 Installation was successful. Now my keyboard is dead. I tried both
runlevel 5
 and 3. The backup version still runs properly. My PC is a Compaq 5WV394
with a 1GHZ AMD processor and a US Int'l keyboard. I can run kbdconfig in
2.4.2-2 but no change.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Select 'Linux' in Lilo in stead of 'Linux bak'.
2.
3.
	

Actual Results:  Normal startup, except 'Initializing USB HID Interface'
takes much longer in 2.4.9-12. KDE starts. I cannot enter my userid and
password there.

Additional info:
Comment 1 Bill Nottingham 2001-12-13 12:38:39 EST
If the USB keyboard doesn't work with the new kernel, that's most likely a
problem with the driver in the kernel.
Comment 2 Arjan van de Ven 2001-12-13 12:41:10 EST
Is this a USB keyboard ?
Comment 3 David Korenberg 2001-12-13 14:43:09 EST
No, it is not a USB keyboard.
Comment 4 David Korenberg 2001-12-19 16:03:05 EST
I have to correct myself...
During startup I see: Initializing USB keyboard [OK]
So it apparantly is a USB keyboard.
Sorry about the confusion.
During startup of version 2.4.2-2 there seem to be IRQ conflicts. 
How can I check this to be sure?
Comment 5 Pete Zaitcev 2001-12-20 18:34:04 EST
This looks like a duplicate of Bug #55878.
The bad news (for me) is that it is made entirely by
my fix to other bug, and we cannot easily undo it.

Arjan, I don't mind if you dup this one.
Comment 6 David Korenberg 2001-12-25 10:37:37 EST
I agree to set it to duplicate. I'm now using a PS/2 keyboard and it's working
fine.
Comment 7 David Korenberg 2002-02-17 11:19:38 EST
I tried the workaraound suggested by Michael Fischer in bug 55878:
add to /etc/rc.d/rc.local:
/sbin/rmmod hid
/sbin/insmod hid

It did not work for my Compaq keyboard.
I was asked to update my service request 195322. The Ticket Manager seems 
unavailable to me. I assume my 60 days of support are over.
Comment 8 Bugzilla owner 2004-09-30 11:39:18 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.