Bug 57474 - linuxconf do wrong when setting quota
linuxconf do wrong when setting quota
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
7.2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-13 10:42 EST by Frank Weng
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Weng 2001-12-13 10:42:33 EST
Description of Problem:
Distribution: Red Hat 7.2
package: linuxconf-1.25r7-3
package: quota3.01pre9-3
file system: ext3

I used linuxconf to set quota at /home, which is a ext3 file system.
The screen shows:

                      Default quota for users and groups

                                             LABEL=/home
                                             User default
           Disk space soft limit    ( ) No limit 10000   
           Disk space hard limit    ( ) No limit 11000
           Disk space grace period  7:00:00:00        

           Files soft limit         ( ) No limit 20000
           Files hard limit         ( ) No limit 22000
           Files grace period       7:00:00:00
as you see, disk space (block) soft 10000/hard 11000
and files (inode) soft 20000/hard 22000.

But when I use `repquota -a`  to see, it showed:

[root@localhost root]# repquota -a
*** Report for user quotas on device /dev/hda5
Block grace time: 7days; Inode grace time: 7days
                        Block limits                File limits
User            used    soft    hard  grace    used  soft  hard  grace
----------------------------------------------------------------------
root      --   32840       0       0              6     0     0       
franklin  --    1008   20000   22000            200 10000 11000
fweng     --      44   20000   22000             11 10000 11000

the block limits and file limits were reversed.
Comment 1 Brent Fox 2002-06-05 12:16:52 EDT
Closing because we don't ship linuxconf anymore
Comment 2 Red Hat Bugzilla 2006-02-21 13:48:18 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.