Bug 57501 - Installer hangs with Adaptec 2100S controller
Installer hangs with Adaptec 2100S controller
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 57500 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-14 07:54 EST by Konrad Zak
Modified: 2014-03-16 22:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-12 16:40:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Konrad Zak 2001-12-14 07:54:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; IDG.pl)

Description of problem:
I get errors during RedHat Linux 7.2 installation on machine with
SCSI PCI card Adaptec 2100S. Installer hangs during packages copying - 
Adaptec card signals with sound alert disk failure.

I have checked everything I could think of. I reduced RAM to 512MB, 
removed additional Adaptec AVA-2904 card, tested disks - they apears to be 
ok. I tried several driver disks from http://linux.adaptec.com, although 
RedHat 7.2 recognize this card with it i2o modules.

Disks are supposed to be configured as RAID-1 array, but tried every 
possible configuration. I removed one disk and tried installer on one disk 
left, but it fails to. The only additional effect was that I could see 
messages like "Read failed" on 1st virtual console.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Try to install system on a box with Adaptec 2100S card	

Additional info:

I can see errors like below on 4th virtual console

<4>/dev/i2o/hda error: Failure communicating to device
<4>end_request: I/O error, dev 50:02 (i2o block), sector 70900
Comment 1 Marek Kassur 2001-12-14 16:57:17 EST
Adaptec I2O RAID controllers required dpt_i2o driver to work properly.
Unfortunately RedHat provided kernel without this driver and with wrong pcitable
file.
I put my unofficial and unsupported driver disk at ftp://bpmok.waw.pl/pub/dptdriver/
Boot installer with isa option (boot: linux isa).
When installer auto load generic i2o modules,
switch to second console and remove it.
Now it's time to load proper dpt_i2o driver.
Insert driver disk, add Adaptec I2O RAID to list and select it.
Install system as usual.
When congratulation screen appear don't reboot,
again switch to console and chroot to freshly installed system.
Correct following files: /usr/share/pcitable, /etc/modules.conf and
/etc/sysconfig/hwconf.
Check for dpt_i2o.o at /lib/modules/2.4.7-10/kernel/drivers/scsi,
if not there extract it from driver disk (use:  zcat modules.cgz | cpio -ivd)
Last thing will be making initial ram disk (mkinitrd /boot/initrd-2.4.7-10.img
2.4.7-10) and modify lilo.conf or grub.conf.

Here is proper pci table:
0x1044  0xa501  "dpt_i2o"       "Adaptec|I2O RAID Controller"
0x1044  0xa511  "dpt_i2o"       "Adaptec|I2O RAID Controller"
Comment 2 Michael Fulbright 2001-12-17 14:34:13 EST
Do you know of this problem matt?
Comment 3 Jeremy Katz 2002-01-02 16:08:59 EST
Do you have better luck with http://people.redhat.com/tcallawa/dpt/?
Comment 4 Konrad Zak 2002-01-03 04:51:48 EST
Drivers and hints supplied by cmarco@astercity.net worked for me without need to
modify /usr/share/pcitable and /etc/modules.conf. I removed i2o_* modules during
install and then loaded dpt_i2o. Before rebooting system I copied dpt_i2o.o
modules to /lib/modules, then I made new init images with '--with dpt_i2o'
option and modified /etc/sysconfig/hwinfo.

Thank you for help.

With the best regards.
Comment 5 Konrad Zak 2002-01-03 04:59:15 EST
*** Bug 57500 has been marked as a duplicate of this bug. ***
Comment 6 Matt Wilson 2002-03-12 16:40:25 EST
Bill, please fix in hwinfo's pci map

Comment 7 Bill Nottingham 2002-03-12 16:43:51 EST
First entry has been fixed in pcitable since the end of October. Second one added.

Note You need to log in before you can comment on or make changes to this bug.