Bug 57505 - Another ia64 ICE while building kdelibs
Another ia64 ICE while building kdelibs
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc (Show other bugs)
1.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-14 11:20 EST by Bernhard Rosenkraenzer
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-19 08:19:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bzip2'ed preprocessor output at -O1 (374.47 KB, application/octet-stream)
2001-12-14 11:47 EST, Bernhard Rosenkraenzer
no flags Details

  None (edit)
Description Bernhard Rosenkraenzer 2001-12-14 11:20:16 EST
Description of Problem:
g++ -DHAVE_CONFIG_H -I. -I. -I.. -I../dcop -I../libltdl -I../kdecore
-I../kdeui
 -I../kssl -I/usr/lib/qt3/include -I/usr/X11R6/include -DQT_THREAD_SUPPORT
-D_R
EENTRANT -I/usr/include/pcre -DNDEBUG -O2 -O2 -fno-exceptions
-fno-check-new -O
1 -DNDEBUG -UDEBUG -DNODEBUG -UDEBUG_ASYNC_TRANSFER -UVPORT_DEBUG
-UDEBUG_IO -U
DEBUG_MESSAGES -UDEBUG_AUTH -UDEBUG_CONNECTION_DATA -DYYDEBUG=0
-UNETWMDEBUG -U
CSS_DEBUG -UCSS_STYLESHEET_DEBUG -USPEED_DEBUG -UKJS_DEBUGGER -UFORMS_DEBUG
-UD
EBUG_LAYOUT -UDEBUG_DRAW_BORDER -UPARSER_DEBUG -UDECODE_DEBUG -UCACHE_DEBUG
-UB
UFFER_DEBUG -UJPEG_DEBUG -UDEBUG_LINEBREAKS -UBOX_DEBUG -UTABLE_DEBUG
-UYYERROR
_VERBOSE -UKJS_DEBUG_MEM -UMIDIOUTDEBUG -UGENERAL_DEBUG_MESSAGES
-D_GNU_SOURCE
-fno-exceptions -fno-check-new -ftemplate-depth-99 -DQT_NO_TRANSLATION
-DQT_CLE
AN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_COMPAT
-Wp,-MD,.deps/libkdecore_la.all_
cpp.pp -c libkdecore_la.all_cpp.cpp  -fPIC -DPIC -o
.libs/libkdecore_la.all_cpp
.o
In file included from libkdecore_la.all_cpp.cpp:21:
kwinmodule.cpp: In member function `QRect KWinModule::workArea(int) const':
kwinmodule.cpp:255: Internal compiler error in simplify_gen_subreg, at
   simplify-rtx.c:2649
Please submit a full bug report,


Version-Release number of selected component (if applicable):
3.1-0.10


How Reproducible:
100%

Steps to Reproduce:
1.  rpm --rebuild kdelibs-3.0.0-0.cvs20011214.1.src.rpm
Comment 1 Bernhard Rosenkraenzer 2001-12-14 11:47:11 EST
Created attachment 40647 [details]
bzip2'ed preprocessor output at -O1
Comment 2 Bernhard Rosenkraenzer 2001-12-14 11:48:12 EST
This one happens only at -O1 -- worked perfectly with -O2 and -O3 before
switching to -O1 because of another gcc bug.
Comment 3 Bernhard Rosenkraenzer 2001-12-14 11:53:37 EST
Works at -O0, as well - it's specific to -O1.
Comment 4 Jakub Jelinek 2001-12-19 08:18:58 EST
Can reproduce this with 3.1-0.10, cannot reproduce with CVS, assume it has
been fixed.

Note You need to log in before you can comment on or make changes to this bug.