Bug 575167 - [abrt] crash in kdepim-6:4.4.1-2.fc12: Process /usr/bin/kmail was killed by signal 11 (SIGSEGV)
[abrt] crash in kdepim-6:4.4.1-2.fc12: Process /usr/bin/kmail was killed by s...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
abrt_hash:af8dce8060b4bb7cd78a110982c...
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-19 12:24 EDT by adam
Modified: 2010-06-21 13:42 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-21 13:42:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (46.37 KB, text/plain)
2010-03-19 12:24 EDT, adam
no flags Details

  None (edit)
Description adam 2010-03-19 12:24:09 EDT
abrt 1.0.8 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/kmail
comment: try to "copy / paste" an image into an email message as "inline"
component: kdepim
executable: /usr/bin/kmail
kernel: 2.6.32.9-70.fc12.x86_64
package: kdepim-6:4.4.1-2.fc12
rating: 4
reason: Process /usr/bin/kmail was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. Start a new Email Message in KMail
2. Open a png image in another program, I was using "Shutter" and had a small image captured from my screen
3. "Copy" the image, as in "right-click / copy" from the other program.
4. Attempt to paste the copied image into the new KMail Message.
5. Select to include it as Inline.
Comment 1 adam 2010-03-19 12:24:11 EDT
Created attachment 401282 [details]
File: backtrace
Comment 2 Steven M. Parrish 2010-03-28 18:25:33 EDT
Thank you for taking the time to report this issue to us.  This is an issue which is best addressed by the upstream developers.

Please file a report at bugs.kde.org , and when done add the upstream report info to this report.

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.

Steven M. Parrish
KDE & Packagekit Triager 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Steven M. Parrish 2010-05-05 07:55:02 EDT
This is an issue which needs to be addressed by the upstream developers.  Please file a report at http://bugs.kde.org  once that is done please add the upstream bug information to this report.  We will monitor the upstream report for a resolution. 

Thanks
Comment 4 Thomas Janssen 2010-06-21 08:19:49 EDT
Does it crash all the time, means is it reproducible? I need at least to know that to file an upstream bug.
Comment 5 adam 2010-06-21 12:37:56 EDT
This seems to have been corrected at some point. I'm now using KDE 4.4.4 on a 32 bit machine and it no longer errors when adding an image attachment.
Comment 6 Thomas Janssen 2010-06-21 13:42:59 EDT
Perfect, thank you very much :) I can't reproduce it on 4.4.85 neither.

Note You need to log in before you can comment on or make changes to this bug.