Bug 57520 - perl-Perl-RPM-0.291-4 rpmprune disagrees with rawhide
Summary: perl-Perl-RPM-0.291-4 rpmprune disagrees with rawhide
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: perl-Perl-RPM   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-14 19:54 UTC by Valdis Kletnieks
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-14 19:54:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Valdis Kletnieks 2001-12-14 19:54:07 UTC
Description of Problem: rpmfind can't load shared libraries


Version-Release number of selected component (if applicable):
perl-Perl-RPM-0.291-4

How Reproducible:
rpmprune --help


Steps to Reproduce:
1. rpmprune --help
2. 
3. 

Actual Results:

% rpmprune --help
Can't load '/usr/lib/perl5/site_perl/5.6.0/i386-linux/auto/RPM/RPM.so' for
module RPM: /usr/lib/librpm-4.0.3.so: undefined symbol: chroot_prefix at
/usr/lib/perl5/5.6.1/i386-linux/DynaLoader.pm line 206.
 at /usr/lib/perl5/site_perl/5.6.0/i386-linux/RPM/Database.pm line 35
Compilation failed in require at
/usr/lib/perl5/site_perl/5.6.0/i386-linux/RPM/Database.pm line 35.
Compilation failed in require at /usr/bin/rpmprune line 12.
BEGIN failed--compilation aborted at /usr/bin/rpmprune line 12.


Expected Results:
A usage message of some sort.

Additional Information:

% rpm -q perl-Perl-RPM perl rpm
perl-Perl-RPM-0.291-4
perl-5.6.1-5.5
rpm-4.0.3-1.04

Have not updated to rpm 4.0.4 because perl-Perl-RPM requires 4.0.3

Comment 1 Jeff Johnson 2001-12-19 18:26:53 UTC
You need the rpm-perl, not the perl-Perl-RPM, package.


Note You need to log in before you can comment on or make changes to this bug.