Bug 57535 - Compiling kernel 2.4.16 fails using gcc3
Compiling kernel 2.4.16 fails using gcc3
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gcc3 (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-14 19:20 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-13 21:56:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-12-14 19:20:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4)
Gecko/20011126 Netscape6/6.2.1

Description of problem:
Tried compiling 2.4.16 stock kernel from ftp.kernel.org and gcc3 bombs out
with 

signal.c:714: Internal compiler error in insn_default_length, at
insn-attrtab.c:223

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Download 2.4.16 stock kernel and uncompress
2. configure kernel as normal(make xconfig)
3. make dep
4. make clean
5. make bzImage - crashes shortly there after.

	

Actual Results:  gcc -D__KERNEL__ -I/usr/src/linux/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fomit-frame-pointer
-fno-strict-aliasing -fno-common -pipe -mpreferred-stack-boundary=2
-march=k6    -DEXPORT_SYMTAB -c signal.c
signal.c: In function `kill_proc':
signal.c:714: Unrecognizable insn:
(insn 124 116 117 (parallel[ 
            (set (reg/f:SI 3 ebx [47])
                (const_int 0 [0x0]))
            (clobber (reg:CC 17 flags))
        ] ) -1 (insn_list:REG_DEP_ANTI 116 (nil))
    (expr_list:REG_UNUSED (reg:CC 17 flags)
        (nil)))
signal.c:714: Internal compiler error in insn_default_length, at
insn-attrtab.c:223
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [signal.o] Error 1
make[2]: Leaving directory `/usr/src/linux/kernel'
make[1]: *** [first_rule] Error 2
make[1]: Leaving directory `/usr/src/linux/kernel'
make: *** [_dir_kernel] Error 2


Expected Results:  make bzImage should of worked.

Additional info:

[root@firegate linux]# gcc -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/3.0.2/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info --enable-shared --enable-threads=posix
--disable-checking --host=i386-redhat-linux
Thread model: posix
gcc version 3.0.2 20010905 (Red Hat Linux 7.1 3.0.1-3)

Machine is currently running 2.4.13, tring to compile 2.4.16 w/ the latest
glibc(2.2.4-19.3) ran up2date and everything is current.

Rebooted machine, removed kernel source tree, started from scratch - same
signal.c error.
Comment 1 Jakub Jelinek 2001-12-19 08:07:24 EST
Can you please attach here preprocessed source (signal.i) which triggers this
(just add -save-temps to the above command line)?
Comment 2 Need Real Name 2001-12-19 09:30:35 EST
Command used:

[root@firegate kernel]# gcc -D__KERNEL__ -I/usr/src/linux/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fomit-frame-pointer -fno-strict-aliasing
-fno-common -pipe -mpreferred-stack-boundary=2 -march=k6 -DEXPORT_SYMTAB -c
-save-temps signal.c

signal.i is at the following url

http://bobcat.bradley.edu/~grunky/signal.i
Comment 3 rodrigc 2002-01-13 21:56:24 EST
Duplicate of GCC PR 4199 which is fixed:
http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=view&pr=4199&database=gcc

Note You need to log in before you can comment on or make changes to this bug.