This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 57539 - kpathsearch is always executed even if fonts already exist
kpathsearch is always executed even if fonts already exist
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-15 00:26 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-21 06:36:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
system log message for dvips (2.45 KB, text/plain)
2001-12-15 00:29 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-12-15 00:26:48 EST
Description of Problem:
Unlike dvips of Red Hat 6.2, the new dvips of Red Hat 7.2 executes
kpathsearch every time dvips has been invoked.

Version-Release number of selected component (if applicable):
dvips(k) 5.86 @1999 Radical Eye Software

How Reproducible:
Always

Steps to Reproduce:
1. dvips input_file
2. 
3. 

Actual Results:
Until kpathsearch action is finished, one has to wait  for a while (30sec
or more, depending on the machine cpu speed), which is a waste of time.  
The dvips result is normal.

Expected Results:


Additional Information:
Comment 1 Need Real Name 2001-12-15 00:29:31 EST
Created attachment 40727 [details]
system log message for dvips
Comment 2 Need Real Name 2001-12-15 01:43:31 EST
The M* option "Don't make fonts" does not work.  The system log message for it
is:

 This is dvips(k) 5.86 Copyright 1999 Radical Eye Software (www.radicaleye.com)
' TeX output 2001.12.15:1047' -> zzz.ps
dvips: Font cmbx12 not found, characters will be left blank.
dvips: Can't open font metric file cmbx12.tfm
dvips: I will use cmr10.tfm instead, so expect bad output.
dvips: ! I can't find cmr10.tfm; please reinstall me with proper paths
Comment 3 Tim Waugh 2001-12-18 06:31:18 EST
Please supply an input file that displays this behaviour.  I don't see it on 
DVI files here.

Do you have the TEXINPUTS environment variable set?

What output does 'rpm -V $(rpm -qa | grep ^tetex)' give?
Comment 4 Need Real Name 2001-12-18 20:04:40 EST
Thank you for your comments.  I write my responses below.
1.  I usually use RevTex and dvips, but the kpathsearch problem occurs also with
the following simple input file:
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
\documentclass[12pt]{article}
\begin{document}
\pagestyle{plain}

1: Today's date is Dec.19, 2001 in English.
% 2: Today's date is "2001G/127n19F|" in Japanese.

\end{document}
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

2. I did not set TEXINPUTS, since I have not had any problems with the Tex
/dvips of other Linux
versions including Red Hat 6.2J.

3. The system message for  'rpm -V $(rpm -qa | grep ^tetex)' gives: .......T  
/usr/bin/dvips

   Additionally and much more seriously, I have a problem with the Kanji fonts;
I cannt run off any documents including Kanji (Chinese) characters (I posted
this problem on the Tech Support 
a month ago, but no answer yet).  Please uncomment the second line of the above
input file and try
dvips. The result for "dvips input_file" on my PC was abnormal termination with
the following messages:

This is dvips(k) 5.86 Copyright 1999 Radical Eye Software (www.radicaleye.com)
' TeX output 2001.12.19:0946' -> zzz.pss
kpathsea: Running mktexpk --mfmode ljfour --bdpi 600 --mag 1+0/600 --dpi 600
cmr12
mktexpk: /var/lib/texmf/pk/ljfour/public/cm/cmr12.600pk already exists.
/usr/bin/dvips: ! Bad VF file min10.vf: character code out of range
ghostview: Cannot open file zzz.pss (No such file or directory)
Comment 5 Tim Waugh 2001-12-19 04:25:25 EST
Oh, you are processing Japanese text.  You need to use pdvips for this now.

With pdvips, do you still get the problem?  If so, can you please try using 
the tetex packages from Red Hat Linux Rawhide (1.0.7-38.2), which I hope to 
release as an enhancement advisory soon?

ftp://ftp.redhat.com/pub/redhat/linux/rawhide/i386/RedHat/RPMS/tetex-*

Thanks.
Comment 6 Need Real Name 2001-12-19 06:30:26 EST
    Yes, I have followed your new instructions, which do not work either.  (I am
using Red Hat 7.2 by "out-of-the-box" default settings, except that I applied
Errata packages found in the Errata Page.)  
More specifically, I first installed by "rpm -Fvh tetex" the tetex-1.0.7-38.2
and related packages, including dvips, fonts, latex, xdvi and afm.  Then, I
rebooted my PC (though may not be necessary), and I executed platex and then
"pdvips" on the simple LaTex input file that I supplied this morning.
The system messages for dvips were exactly what I got previously, as shown
below.
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
This is dvipsk 5.86 p1.5e Copyright 1996-2001 ASCII Corp.(www-ptex@ascii.co.jp)
based on dvipsk 5.86 Copyright 1999 Radical Eye Software (www.radicaleye.com)
' TeX output 2001.12.19:2005' -> zzz.ps
kpathsea: Running mktexpk --mfmode ljfour --bdpi 600 --mag 1+0/600 --dpi 600
cmr12
mktexpk: /var/lib/texmf/pk/ljfour/public/cm/cmr12.600pk already exists.
pdvips: Can't open font metric file rml.tfm
pdvips: I will use cmr10.tfm instead, so expect bad output.
pdvips: ! I can't find cmr10.tfm; please reinstall me with proper paths
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
     I'd like to have your further tech support on this issue.  Thank you.
Comment 7 Tim Waugh 2001-12-19 06:33:18 EST
Well, I can't reproduce the problem.  Please use the 'Create a new attachment' 
link to actually attach the file you are using, to make sure that we are 
really looking at the same thing.

Thanks.
Comment 8 Need Real Name 2001-12-21 06:36:01 EST
    OK, I have confirmed that the "updated" tetex packages -
tetex-***-1.0.7-38.2 of 12/12/01 now returns the correct results for pdvips. 
The problems with the old tetex that I reported are now resolved.  (The reason
why I did not get the right result was that one setting when testing the
"updated" tetex was not right.)   I really appreciate your help.
    On the other hand, "pxdvi" still displays an odd character (U shaped
character - blank ?) for Kanji characters.
Comment 9 Tim Waugh 2001-12-21 11:56:26 EST
Yes, I think that's because you need to set the right locale setting.  Perhaps 
'LANG=jp_JP.eucJP' or something?  I forget what it is.  Anyway, that is a 
VFlib2 problem, not a pxdvi one.

Thanks for the feedback.
Comment 10 Need Real Name 2001-12-22 20:01:01 EST
   Following your advice, I set LANG='ja_JP.euc' (this should be a correct
keyword) in .bashrc, but it did not work.  
   In the previous Red Hat 6.2J, "xdvi" (not pxdvi) worked fine with
Japanese-font texts without specifying anyting special.  I hope that the basic
packages should be left intact unless otherwise necessary when the version
number is updated.  Thank you.

Note You need to log in before you can comment on or make changes to this bug.