Bug 57544 - display cannot handle many xpm's which both ee and rh71 display can, rawhide `fix' doesn't compile
display cannot handle many xpm's which both ee and rh71 display can, rawhide ...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ImageMagick (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-15 05:14 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-12 06:06:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-12-15 05:14:00 EST
Description of Problem:
The display program that is part of ImageMagick cannot read may xpm's
that ee, xv *and* versions of ImageMagick as bundled with other rh 
releases can read.

It *can* read some xpms. Without loking at the source, I guess that 
those xpms have a different format
( they have /* pixels */ and /* columns rows colors chars-per-pixel */ )

Version-Release number of selected component (if applicable):
ImageMagick-5.3.8-3

How Reproducible:
100%,

Steps to Reproduce:
~$ cd /usr/share/pixmaps
/usr/share/pixmaps$ display Ant.xpm 
display: Unexpected end-of-file (Ant.xpm) [No such file or directory].

Additional Information:
Before you mark this as a duplicate of
http://www.redhat.com/bugzilla/show_bug.cgi?id=55692
please explain how upgrading to a *rawhide* version can be considered
a fix.
And besides the rawhide rpm doesn't compile on a redhat 7.2 system
because the person building it appears to have used tools 
(automake-1.5) which are not yet released (maybe because they cause
problems when building other packages?) by redhat 
(they are available from gnu, PLD, SuSE , ..):

~# rpm --rebuild ImageMagick-5.4.1-1.src.rpm 
...
 Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.41451
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd ImageMagick-5.4.1
+ libtoolize --force
You should update your `aclocal.m4' by running aclocal.
+ aclocal
+ automake
Makefile.am:35: require version 1.5, but have 1.4-p5
coders/Makefile.am:31: require version 1.5, but have 1.4-p5
+ :
+ autoconf
autoconf: configure.in: No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.41451 (%build)
 
One *can* install automake-1.5 from source and then compile ImageMagick 
from source but then what is the point in having rpm.

strace output:
-----------------------------------------------------------
open("/proc/meminfo", O_RDONLY)         = 4
fstat64(4, {st_mode=S_IFREG|0444, st_size=0, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x401ba000
read(4, "        total:    used:    free:"..., 4096) = 571
close(4)                                = 0
munmap(0x401ba000, 4096)                = 0
munmap(0x401b8000, 6328)                = 0
write(2, "display: Unexpected end-of-file", 31) = 31
write(2, " (nedit.xpm)", 12)            = 12
open("/usr/share/locale/en_US/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT
(No such file or directory)
open("/usr/share/locale/en/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No
such file or directory)
write(2, " [No such file or directory]", 28) = 28
write(2, ".\n", 2)                      = 2
ioctl(0, 0x5401, {B38400 opost isig icanon echo ...}) = 0
-----------------------------------------------------------------
Or if I set the LANG=en_GB 
-----------------------------------------------------------------
read(4, "/dev/hda2 / ext3 rw 0 0\nnone /pr"..., 4096) = 542
close(4)                                = 0
munmap(0x401ac000, 4096)                = 0
open("/proc/meminfo", O_RDONLY)         = 4
fstat64(4, {st_mode=S_IFREG|0444, st_size=0, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x401ac000
read(4, "        total:    used:    free:"..., 4096) = 571
close(4)                                = 0
munmap(0x401ac000, 4096)                = 0
munmap(0x401a8000, 14298)               = 0
write(2, "display: Unexpected end-of-file", 31) = 31
write(2, " (abiword_48.xpm)", 17)       = 17
write(2, " [No such file or directory]", 28) = 28
write(2, ".\n", 2)                      = 2
---------------------------------------------------------------------
Comment 1 Karsten Hopp 2003-05-12 06:06:35 EDT
We sometimes ask the bug reporter to verify with the rawhide package that the
bug is fixed.
closed 'rawhide' means that we won't release an errata for this bug, but it will 
be fixed in the next version.

Note You need to log in before you can comment on or make changes to this bug.