Bug 575742 - RFE: %packages section to be able to include a flat file package list
RFE: %packages section to be able to include a flat file package list
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pykickstart (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-22 06:14 EDT by Jasper O'neal Hartline
Modified: 2010-03-23 10:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-23 10:17:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jasper O'neal Hartline 2010-03-22 06:14:55 EDT
Description of problem:
Using Kickstart with Anaconda I notice I cannot generate
A list of currently installed files on the system to send into a single flat file to use as a included package list file in Kickstart %packages section.

The reason this is useful is for example, making a kickstart system include
any packages I have installed currently or any package list file generated by some other means based on whatever criteria deemed important, to be used in %packages section.

So far the only suggestion I have recieved was to do some preprocessing before hand and insert the packages into a kickstart file, for example using a kickstart file creation mechanism. While this seems it is very easily done, it would just be some added benefit to be able to have %packages recognize an options or switch for including a flat file with package names on each line for inclusion in the package payload to the target.

Example: 

%packages --excludedocs --nobase
gdm
gnome-session
openbox
fluxbox
include(/home/user/packagelist.txt)

That or something similar.
Remember this is an RFE, not a filed bug.. thanks.
 
Please advise. 



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jasper O'neal Hartline 2010-03-22 06:22:41 EDT
I also forgot to mention that allowing this construct, will ease modularity with kickstart files when the package list to include may be huge.
This makes it much easier to administrate and segregate pieces of kickstart installs which could in turn make things more flexible with what package set is to be included.

I'd much rather for example have 5 flat files with specifications for different packages, than to have 5 seperate kickstart files when the only thing that will differ in the whole kickstart process is the package set.

I know the Fedora Project produces nightly builds and I cannot say for sure they even use the %packages section to specify which packages are to be installed, but even if they did I believe they would let the comps take care of ti since it is an official nightly LiveCD build, meaning they can simply do @base and @gnome-desktop

or @games

Rather than having huge kickstart files, unfortunately this doesn't work for the general public when wanting to specify particular package sets, and only those packages directly, without specifying the group.

Like using
%packages --nodefault
fluxbox
openbox
gnome-session
gnome-panel
@thisgroup

This just makes package selection in kickstart situation this much more modular, flexible and fine grained. 
(Assumed the package file list can also specify what NOT to install if it wants)
Like:
(package.list):
-fluxbox
openbox
-NetworkManager
gnome-panel

Maybe this does or doesn't make sense to allow, please advise.
Comment 2 Chris Lumens 2010-03-22 10:44:25 EDT
kickstart already has a %include directive that's briefly documented at https://fedoraproject.org/wiki/Anaconda/Kickstart.  This can be used within the %packages section.  Is that what you're looking for?
Comment 3 Jasper O'neal Hartline 2010-03-22 19:39:46 EDT
Yes, that is exactly what I was looking for.
Ok I looked and for some reason did not come across this.
Interesting, ok thanks. Works as I expected.

Thanks a lot.

Note You need to log in before you can comment on or make changes to this bug.