Bug 575860 - [abrt] crash in eclipse-platform-1:3.5.1-22.fc12: Process /usr/lib/eclipse/eclipse was killed by signal 6 (SIGABRT)
[abrt] crash in eclipse-platform-1:3.5.1-22.fc12: Process /usr/lib/eclipse/ec...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
abrt_hash:a3b524b7abfccc2f48dba40ca1d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-22 11:00 EDT by Steven F. LeBrun
Modified: 2010-08-24 18:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-24 18:26:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (103.86 KB, text/plain)
2010-03-22 11:00 EDT, Steven F. LeBrun
no flags Details
XML File that caused Eclipse to crash when Eclipse tried to open file into editor. (9.31 KB, application/xml)
2010-03-25 00:00 EDT, Steven F. LeBrun
no flags Details

  None (edit)
Description Steven F. LeBrun 2010-03-22 11:00:30 EDT
abrt 1.0.8 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/eclipse/eclipse
comment: Note that this is an Android project that uses the ADT Plug-in
component: eclipse
executable: /usr/lib/eclipse/eclipse
kernel: 2.6.32.9-70.fc12.i686.PAE
package: eclipse-platform-1:3.5.1-22.fc12
rating: 3
reason: Process /usr/lib/eclipse/eclipse was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. Open a file in <workspace><project>res/xml/file.xml
2.
3.
Comment 1 Steven F. LeBrun 2010-03-22 11:00:38 EDT
Created attachment 401789 [details]
File: backtrace
Comment 2 Steven F. LeBrun 2010-03-24 23:55:26 EDT

How to reproduce
-----
1. Create an Android project (requires ADT plugin)
2. Add an XML document to the res/xml directory by hand
3. Open Eclipse (or refresh the project to pick up the XML file)
4. Attempt to open the XML file in Eclipse.
    - This is when Eclipse crashes


Comment
-----
Working on an Android project using the Android Development Tools (ADT) Plug-In.  Created an XML file outside of the Eclipse Android project and placed the XML file in the res/xml directory.  Each time that I try to open the XML file, Eclipse crashes.
Comment 3 Steven F. LeBrun 2010-03-25 00:00:44 EDT
Created attachment 402454 [details]
XML File that caused Eclipse to crash when Eclipse tried to open file into editor.

The XML File that caused Eclipse to crash when Eclipse tried to open the file (so I could edit the XML file) was generated using OxygenXML 11.1.  There is no schema file associated with the XML document.
Comment 4 Andrew Overholt 2010-08-23 15:26:38 EDT
Steven, can you make this happen with just what is shipped in Fedora?  I'm sure you can understand that we can't support plugins that aren't in the distro.
Comment 5 Steven F. LeBrun 2010-08-24 01:05:01 EDT
Not anymore.  I ended up uninstalling Eclipse and reinstalling it and only some of the plugins that I had installed before.

The current version of Eclipse is working fine.
Comment 6 Andrew Overholt 2010-08-24 18:26:44 EDT
Thanks for the info.  Closing.

Note You need to log in before you can comment on or make changes to this bug.