Bug 57587 - kernel-2.4.9-13 hangs on keyboardless pc
Summary: kernel-2.4.9-13 hangs on keyboardless pc
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-17 00:41 UTC by Carlos Paz
Modified: 2007-04-18 16:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 23:47:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Carlos Paz 2001-12-17 00:41:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
The latest released kernel hangs on boot when the pc doesn't have a 
keyboard attached, previous kernel boots ok.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. setup the pc to boot without a keyboard
2. upgrade to the latest kernel

	

Actual Results:  Upgraded to the latest kernel

Expected Results:  Boot without problems

Additional info:

kernel-2.4.9-13 
Intel 815EEA2
Pentium III 1GHz

kernel-2.4.7-10 boots fine.

Comment 1 Eric Harrison 2001-12-31 01:45:48 UTC
Repeatable on systems with USB keyboards

Comment 2 Eric Harrison 2001-12-31 01:56:30 UTC
Seems to be APM related. Appending "apm=off" to the boot prompt allows system to
boot. Lockups happen right after "mxt_scan_bios: enter".

Comment 3 Marcel 2002-05-14 15:43:58 UTC
Occurs in the 7.3 (2.4.18-3,4) kernels also.

Comment 4 Ben Greear 2002-05-30 06:41:39 UTC
Occurs on various P-III motherboards (Intel & Tyan).

Also occurs on various kernels, including stock kernels
from kernel.org.

Comment 5 StK 2002-10-17 08:51:20 UTC
Solved in 2.4.18-14 from RH 8.0

Comment 6 StK 2002-10-17 08:57:53 UTC
PS: And no problem with 2.4.7-10
from RH 7.2
But the "apm=off" helps! thanks!

Comment 7 StK 2002-10-17 10:37:30 UTC
Since my last message, a new ERRATA Kernel is available.

2.4.18-17.7.x for solves the problem under RH 7.2 and 7.3


Note You need to log in before you can comment on or make changes to this bug.