Bug 57593 - missing HAVE_GETMNTENT, fnmatch cruft in rpm 4.0.3
missing HAVE_GETMNTENT, fnmatch cruft in rpm 4.0.3
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-16 22:58 EST by Red Hat Bugzilla
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-16 23:00:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add HAVE_GETMNTENT template to acconfig.h (367 bytes, patch)
2001-12-16 22:59 EST, Red Hat Bugzilla
no flags Details | Diff
comment out fnmatch in configure.in -- it's not used/needed (832 bytes, patch)
2001-12-16 23:00 EST, Red Hat Bugzilla
no flags Details | Diff

  None (edit)
Description Red Hat Bugzilla 2001-12-16 22:58:46 EST
rpm-4.0.3 has `config.h.in' that can't be automatically
recreated from configure.in & acconfig.h, because acconfig.h
is missing "templates" for two things that occur in the existing
config.h.in -- HAVE_GETMNTENT and fnmatch.

I emailed Jeff about the fnmatch thing on 2001 Jul 31, and
it was explained that it was essentially cruft.

The HAVE_GETMNTENT is easily fixed with a patch to
acconfig.h.

I'll be attaching a patch or two to fix this.
Comment 1 Red Hat Bugzilla 2001-12-16 22:59:51 EST
Created attachment 40788 [details]
add HAVE_GETMNTENT template to acconfig.h
Comment 2 Red Hat Bugzilla 2001-12-16 23:00:51 EST
Created attachment 40789 [details]
comment out fnmatch in configure.in -- it's not used/needed
Comment 3 Red Hat Bugzilla 2001-12-19 14:35:52 EST
Fixed in CVS, should be in rpm-4.0.4-0.4 and later.

Note You need to log in before you can comment on or make changes to this bug.