Bug 576003 - [abrt] crash in krb5-workstation-1.7.1-2.fc12: Process /usr/kerberos/bin/klist was killed by signal 11 (SIGSEGV)
[abrt] crash in krb5-workstation-1.7.1-2.fc12: Process /usr/kerberos/bin/klis...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: krb5 (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Fedora Extras Quality Assurance
abrt_hash:89b70b66cbb89acf6b015efd4a7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-22 20:12 EDT by Nelson Elhage
Modified: 2010-09-21 17:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-21 17:59:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (1.40 KB, text/plain)
2010-03-22 20:12 EDT, Nelson Elhage
no flags Details

  None (edit)
Description Nelson Elhage 2010-03-22 20:12:10 EDT
abrt 1.0.8 detected a crash.

architecture: x86_64
cmdline: klist -s
component: krb5
executable: /usr/kerberos/bin/klist
kernel: 2.6.31.5-127.fc12.x86_64
package: krb5-workstation-1.7.1-2.fc12
rating: 3
reason: Process /usr/kerberos/bin/klist was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

backtrace
-----
Core was generated by `klist -s'.
Program terminated with signal 11, Segmentation fault.
#0  0x00007f76b6c1e816 in __strcmp_ssse3 () from /lib64/libc.so.6

Thread 1 (Thread 18783):
#0  0x00007f76b6c1e816 in __strcmp_ssse3 () from /lib64/libc.so.6
No symbol table info available.
#1  0x00007f76b81c895d in krb5_cc_get_name ()
No symbol table info available.
#2  0x00007f76b81c8f47 in main ()
No symbol table info available.
From                To                  Syms Read   Shared Object Library
0x00007f76b7d01540  0x00007f76b7d5cf18  Yes (*)     /lib64/libkrb5.so.3
0x00007f76b7ac25c0  0x00007f76b7adb778  Yes (*)     /lib64/libk5crypto.so.3
0x00007f76b78bb220  0x00007f76b78bbcf8  Yes (*)     /lib64/libcom_err.so.2
0x00007f76b76b36c0  0x00007f76b76b7798  Yes (*)     /lib64/libkrb5support.so.0
0x00007f76b74afaa0  0x00007f76b74affa8  Yes (*)     /lib64/libkeyutils.so.1
0x00007f76b72998c0  0x00007f76b72a7eb8  Yes (*)     /lib64/libresolv.so.2
0x00007f76b707d550  0x00007f76b708d028  Yes (*)     /lib64/libselinux.so.1
0x00007f76b6e74de0  0x00007f76b6e75998  Yes (*)     /lib64/libdl.so.2
0x00007f76b6b19860  0x00007f76b6c211bc  Yes (*)     /lib64/libc.so.6
0x00007f76b68e4390  0x00007f76b68ef918  Yes (*)     /lib64/libpthread.so.0
0x00007f76b7fa6af0  0x00007f76b7fbe3d4  Yes (*)     /lib64/ld-linux-x86-64.so.2
(*): Shared library is missing debugging information.
$1 = 0x0
No symbol table is loaded.  Use the "file" command.

How to reproduce
-----
1. Run `klist -s' with an expired credentials cache.
Comment 1 Nelson Elhage 2010-03-22 20:12:12 EDT
Created attachment 401889 [details]
File: backtrace
Comment 2 Nalin Dahyabhai 2010-09-21 17:15:39 EDT
That seems to work when I try it here.  What (if anything) is $KRB5CCNAME set to?  The implementation of krb5_cc_get_name() ends up calling code that's specific to the type of ccache (FILE, KEYRING, etc.), but none of them use strcmp() so far as I can see.

Are you still seeing this?  If you are, can you run 'debuginfo install krb5-libs' as root and either attach or paste the resulting backtrace?
Comment 3 Nelson Elhage 2010-09-21 17:45:49 EDT
I've since reinstalled that machine and can't repro any more, so if you can't repro, I guess we can just close this.

Sorry for the trouble.
Comment 4 Nalin Dahyabhai 2010-09-21 17:59:22 EDT
No worries.  Thanks for the quick follow up!

Note You need to log in before you can comment on or make changes to this bug.