This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 576136 - evolution-connector crashes on ldap [NEEDINFO]
evolution-connector crashes on ldap
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution-connector (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Matthew Barnes
desktop-bugs@redhat.com
: Patch
Depends On:
Blocks: 569781 648910
  Show dependency treegraph
 
Reported: 2010-03-23 06:59 EDT by ritz
Modified: 2014-06-02 09:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:06:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
pm-rhel: needinfo? (rkhadgar)


Attachments (Terms of Use)
patch based on upstream (14.20 KB, patch)
2010-03-23 07:01 EDT, ritz
no flags Details | Diff
patch based on upstream code (17.22 KB, patch)
2010-10-13 06:07 EDT, ritz
no flags Details | Diff

  None (edit)
Description ritz 2010-03-23 06:59:50 EDT
Description of problem:
crash, trace attached

Version-Release number of selected component (if applicable):
evolution-connector-2.12.3

How reproducible:
random

Steps to Reproduce:
n/a
  
Actual results:
crash

Expected results:
no crash

Additional info:
Gnome bug #303067, and 540346 


#4  <signal handler called>
#5  0x00914752 in g_type_check_instance_cast () from /lib/libgobject-2.0.so.0
#6  0x0574bea1 in ?? () from /usr/lib/libORBit-2.so.0
#7  0x0574c03a in ORBit_object_get_connection () from /usr/lib/libORBit-2.so.0
#8  0x0574a38f in ORBit_small_invoke_stub () from /usr/lib/libORBit-2.so.0
#9  0x0574a60e in ORBit_small_invoke_stub_n () from /usr/lib/libORBit-2.so.0
#10 0x05757882 in ORBit_c_stub_invoke () from /usr/lib/libORBit-2.so.0
#11 0x0528652f in GNOME_Evolution_Addressbook_BookView_start (_obj=
Could not find the frame base for "GNOME_Evolution_Addressbook_BookView_start".
) at Evolution-DataServer-Addressbook-stubs.c:46
#12 0x0528a26b in e_book_view_start (book_view=<value optimized out>)
   at e-book-view.c:225
#13 0x0086c376 in start_view (contact_store=<value optimized out>,
   view=<value optimized out>) at e-contact-store.c:668
#14 0x0086c41e in query_contact_source (contact_store=<value optimized out>,
   source=<value optimized out>) at e-contact-store.c:779
#15 0x0086d2a2 in e_contact_store_set_query (
   contact_store=<value optimized out>, book_query=<value optimized out>)
   at e-contact-store.c:986
#16 0x0087438c in update_completions_on_idle_cb (
   name_selector_entry=<value optimized out>) at e-name-selector-entry.c:508
#17 0x00741621 in ?? () from /lib/libglib-2.0.so.0
#18 0x00743372 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#19 0x00746366 in ?? () from /lib/libglib-2.0.so.0
#20 0x00746727 in g_main_loop_run () from /lib/libglib-2.0.so.0
#21 0x05856a23 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#22 0x0805d9b9 in main (argc=2, argv=0xbfeea614) at main.c:602
Comment 1 ritz 2010-03-23 07:01:47 EDT
Created attachment 402029 [details]
patch based on upstream
Comment 3 RHEL Product and Program Management 2010-08-09 15:36:35 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 4 ritz 2010-10-13 06:07:25 EDT
Created attachment 453160 [details]
patch based on upstream code

commit 0356644f138d9960b4ad5274fd10bf1a91c2bed8
Author: Milan Crha <mcrha@redhat.com>
Date:   Thu Mar 27 10:17:36 2008 +0000   
        ** Fix for bug #303067
    
        * addressbook/e-book-backend-gal.c:
        Guard access to priv->ldap with its mutex.
        Also do not use local copy of priv->ldap when reconnect can change it.
    

-- additional patches to above

commit ccf5bf39bee378b65b387b8c7a41c42a99157e7c
Author: Suman Manjunath <msuman@src.gnome.org>
Date:   Mon Sep 1 04:04:58 2008 +0000
    Milan Crha  <mcrha@redhat.com> ** Fix for bug #473924 (Prevent crash on invalid call sequence).
    

commit 49e8bddda7ca6f8ce49d3616c4a514b187522082
Author: Milan Crha <mcrha@redhat.com>
Date:   Fri Sep 5 06:30:28 2008 +0000
        ** Fix for bug #550160
        * addressbook/e-book-backend-gal.c: (func_contains):
        Be able to search for "Name contains" like queries.
    
commit 1eceae4fe395716f4ae597d66975941eed2fce43
Author: Tor Lillqvist <tml@novell.com>
Date:   Thu May 8 01:32:38 2008 +0000    
        * addressbook/e-book-backend-exchange.c (update_cache): Remove
        pointless code that constructed a timestamp for the cache file


commit a01322b6285135e85cd2577cb4c52ceeee0e34a2
Author: Srinivasa Ragavan <sragavan@novell.com>
Date:   Fri Feb 15 20:28:35 2008 +0000
        ** Fix for bug #516252    
        * addressbook/e-book-backend-exchange.c:
        (e_book_backend_exchange_connect): Determine that we are in offline if
        we cant get info from the server.
Comment 5 RHEL Product and Program Management 2011-05-31 11:07:52 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2014-03-07 08:38:29 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 7 RHEL Product and Program Management 2014-06-02 09:06:48 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.