This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 57651 - installer hangs on a dual alpha server
installer hangs on a dual alpha server
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-18 05:14 EST by Jean-Christophe Diomard-Arrazau
Modified: 2007-04-18 12:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-21 11:17:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jean-Christophe Diomard-Arrazau 2001-12-18 05:14:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
this is based on the CRM request #195366 
the installation attempt on this configuration hangs during kernel launching

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
hardware configuration :
Alpha server 2100a 5/250rm
2 CPU of 250 MHz,  512Mb mem

SRM cdrom drive
dk600.6.0.2001.0 DKA 600 RRD45 0436

1. at boot  :
# boot dka600 -file /kernels/vmlinux.gz "root=/dev/scd0
initrd=images/ramdisk/img"

(this as been tried with the boot floppy too the result is the same )
2.
3.
	

Actual Results:  the messages seems to launch things correctly but,
before the compressed kernel is loaded the system hangs

here are the displayed messages :
block 0 of dka600.0.2001.0 is a valid boot block
bootstrap code read in
base = 200000,image_start = 0,image_byte =14600
initializing HWRPB at 2000
initializing page table at 1fff0000
initializing machine state
setting affinity to primary CPU
jumping to bootstrap code
aboot: switching to OSF/1 PAL code version 1.22
aboot:booting from device 'SCSI 0 2001 0 6 600 0 0'
aboot: no disklabel found
iso:Max size: 332353 Log zone size:2048
iso: First datazone: 28 Root inode number: 57344
aboot: loading compressed /kernels/vmlinux.gz...
aboot: zero-filling 191480 bytes at 0xffffffc0000ae9b10
aboot: loading initrd (1474560 bytes/1440 blocks) at 0xffffffc001d8c000
aboot:starting kernel /kernels/vmlinux.gz with argument root=/dev/scd0

and then the system hangs

Expected Results:  load of the kernel and intallation of the O.S.

Additional info:

you can faind all the other informations i collected in the CRM interface
Comment 1 Jeremy Katz 2002-01-02 16:35:27 EST
Bryce -- any ideas on this one?
Comment 2 Brent Fox 2002-01-20 10:38:38 EST
Bryce, any input here?
Comment 3 Phil Copeland 2002-01-21 11:17:32 EST
Yes,.. you're doomed.

This is kinda odd in that the bootloader (aboot) has worked fine

I'm not so sure about that boot line though

boot dka600 -fl -fi

should happily pull up the menu of kernels that can be loaded
Non then, that said I have an alpha at home with 2 cdrom drives
one is locked to 2048 bytes/sec and the other to 512 bytes/sector
One works, the other doesn't... I dunno if  the CDRom drive has the
jumper settings to allow it to change read sector size on it but I've
found that to be a problem in all releases.

Phil
=--=
Comment 4 Jeremy Katz 2002-01-21 20:35:49 EST
I defer to bryce's wisdom on this :)
Comment 5 Phil Copeland 2002-01-22 09:37:34 EST
Coward 8)

Note You need to log in before you can comment on or make changes to this bug.