Bug 57654 - pulse does not start all applicable nannies
pulse does not start all applicable nannies
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: piranha (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
Brian Brock
:
: 15911 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-18 05:38 EST by Sébastien BONNET
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-17 17:03:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to start one nanny for each (VIP,RIP,port,proto) instead of one for each (RIP,port,proto). Also correctly handle SIGHUP in pulse. (3.19 KB, patch)
2002-01-02 10:10 EST, Sébastien BONNET
no flags Details | Diff

  None (edit)
Description Sébastien BONNET 2001-12-18 05:38:23 EST
Description of Problem:
When using the same real server in several virtual servers hosted on the 
same machine, pulse does not start multiple nannies for this real server, 
but just one matching the first virtual server.
Thus, there is no ipvsadm entry for this real server except for the first 
declared virtual server.

Version-Release number of selected component (if applicable):
piranha 0.5.5-8
ipvsadm 1.17
ipvs 0.8.1

How Reproducible: anytime

Steps to Reproduce:
1. setup a piranha cluster
2. Use a lvs.conf somewhat like :
virtual http1 {
     active = 1
     address = 172.22.48.210 eth0:1
     vip_nmask = 255.255.240.0
     port = 80
     scheduler = wrr
     protocol = tcp
     server lilas {
         address = 172.16.0.101
         active = 1
         weight = 3
     }
     server pcpgn {
         address = 172.16.0.102
         active = 1
         weight = 2
     }
}
virtual http2 {
     active = 1
     address = 172.22.48.209 eth0:2
     vip_nmask = 255.255.240.0
     port = 80
     scheduler = wlc
     protocol = tcp
     server lilas {
         address = 172.16.0.101
         active = 1
         weight = 1
     }
     server pcpgn {
         address = 172.16.0.102
         active = 1
         weight = 1
     }
}
3. Start pulse, and then notice that there are only two nannies running, 
instead of four.
Comment 1 Sébastien BONNET 2002-01-02 10:10:29 EST
Created attachment 41611 [details]
Patch to start one nanny for each (VIP,RIP,port,proto) instead of one for each (RIP,port,proto). Also correctly handle SIGHUP in pulse.
Comment 2 Phil Copeland 2002-01-17 17:03:53 EST
*** Bug 15911 has been marked as a duplicate of this bug. ***
Comment 3 Phil Copeland 2002-01-17 17:06:33 EST
Danke,.. applied these patchs to 0.6.0-15 so you should see the results in
0.6.0-16 and higher

Cheers

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.