Bug 57670 - --preload option fails if you use an "="
--preload option fails if you use an "="
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-18 12:18 EST by Robert P. J. Day
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-18 13:09:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert P. J. Day 2001-12-18 12:18:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
  from the source of the "mkinitrd" script, it seems that you have
the flexibility, for options like --fstab and --with to either use
an "=" sign or to leave it out:

  --with ext3
  --with=ext3

this is because those cases search for patterns such as 
--fstab*) and --with*).  however, the same is not true for
the --preload option, which recognizes only --preload),
and will fail if you use an "=", despite what the man page
says.

  if you use an "=", the script will interpret what you've typed
as a target, as in target=--preload=ext3.  simple solution:
add an asterisk in the case pattern for --preload, just as there
is for --fstab and --with.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.mkinitrd -v --preload=ext3 /tmp/initrd.img 2.4.7-10
2.
3.
	

Additional info:
Comment 1 Robert P. J. Day 2001-12-18 12:28:35 EST
  pedantic point:  the --image-version option is not mentioned in either
the man page or info page, either.
Comment 2 Robert P. J. Day 2001-12-18 12:45:41 EST
  and while i'm beating up on mkinitrd, a couple more (minor) nitpicks:

1) the --image-version option is also not documented in the man page, 
   although it is listed in the usage message from mkinitrd

2) while the man page states the RAID modules will be loaded if the root
   partition is on raid, it doesn't mention that it will also load
   the ext3 (and jbd) modules if the root partition is ext3 and that is 
   currently a module.  that's a pretty important point to emphasize, i think.
Comment 3 Robert P. J. Day 2001-12-18 13:08:57 EST
  oops, small correction to a previous addition.  i repeated myself when i
said --image-version is not documented.  i meant, in the second case, to
say that --nocompress is not documented.  mea culpa.
Comment 4 Erik Troan 2002-01-11 11:27:37 EST
Fixed in mkinitrd-3.3

Note You need to log in before you can comment on or make changes to this bug.