Bug 57683 - kghostview runs with 99% cpu usage
Summary: kghostview runs with 99% cpu usage
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdegraphics   
(Show other bugs)
Version: 7.2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-18 21:30 UTC by Markus
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-20 12:50:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Markus 2001-12-18 21:30:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6+) Gecko/20011212

Description of problem:
kghostview runs with every pdf and ps-file with 99% cpu-usage. the new
kde2.2.2 has the same problem. 

%CPU : USER     :   PID : COMMAND
95.9 : markus   : 14808 : kghostview file:/home/markus/l2kurz.pdf -caption
PS/PDF Viewer -icon kghostview -min 
0.2 : markus   : 14811 : gs -sDEVICE=x11 -dTextAlphaBits=4
-dGraphicsAlphaBits=2 -dMaxBitmap=10000000 -dNOPLA


Version-Release number of selected component (if applicable):
0.12

How reproducible:
Always

Steps to Reproduce:
1.open a pdf or postscript file
2.
3.
	

Additional info:

since kde 2.2

Comment 1 Alexei Podtelezhnikov 2001-12-18 23:27:51 UTC
I suspect that you are an upgrading freak, like i am. ... just judging by you 
version of mozilla.
Do you use qt-2.3.2? If so, do you see the problem with 2.3.1?
Downgrading might help. Report back

Comment 2 Markus 2001-12-20 12:50:12 UTC
i now use qt2.3.1-2.3.2 was *really* buggy...

i had the problem with roswell and wrote to the kde bug tracking system-but
nothing happened. 



Comment 3 Bernhard Rosenkraenzer 2002-01-17 14:53:38 UTC
Fixed in the current tree

Comment 4 Alexei Podtelezhnikov 2002-01-18 01:43:54 UTC
The fix is painfully simple:
Settings/Configure KGhostView/Ghostscript and click "Configure..."


Note You need to log in before you can comment on or make changes to this bug.