Bug 57696 - shift-F12 in fdisk crashes kernel
shift-F12 in fdisk crashes kernel
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-19 01:32 EST by Chris Ricker
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-20 22:16:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2001-12-19 01:32:17 EST
Do a text-mode custom install off of CD, and use fdisk instead of Disk
Druid to partition the hard drive.  While in fdisk, press <Shift>-<F12>. 
The install will die at that point with a kernel panic (error mounting root
fs).

I have no idea what, if anything, <Shift>-<F12> is supposed to do (this was
discovered by accident ;-), but it's highly reproducible, since it's
occurred on all three systems where I've tried it.

It does seem to be a problem with the installer, since <Shift>-<F12> in
fdisk on a running system doesn't cause the kernel to panic.
Comment 1 Jeremy Katz 2002-01-02 16:43:05 EST
I'm unable to reproduce this at all here...
Comment 2 Chris Ricker 2002-01-08 16:42:32 EST
I can reproduce it at will on one set of identical machines here in the office.
 It looks like it's something specific about that hardware since the only
machines I see it on have the same configurations.

Let me know if you need more info about the machines.  Here's the first portion
of dmesg (up through drive ID) which might immediately be relevant:

Linux version 2.4.9-13 (bhcompile@stripples.devel.redhat.com) (gcc version 2.96 
20000731 (Red Hat Linux 7.1 2.96-98)) #1 Tue Oct 30 20:11:04 EST 2001
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000000fff0000 (usable)
 BIOS-e820: 000000000fff0000 - 000000000fff3000 (ACPI NVS)
 BIOS-e820: 000000000fff3000 - 0000000010000000 (ACPI data)
 BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
Scanning bios EBDA for MXT signature
On node 0 totalpages: 65520
zone(0): 4096 pages.
zone(1): 61424 pages.
zone(2): 0 pages.
Kernel command line: ro root=/dev/hda3
Initializing CPU#0
Detected 501.143 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 999.42 BogoMIPS
Memory: 252604k/262080k available (1723k kernel code, 7164k reserved, 91k data, 
224k init, 0k highmem)
Dentry-cache hash table entries: 32768 (order: 6, 262144 bytes)
Inode-cache hash table entries: 16384 (order: 5, 131072 bytes)
Mount-cache hash table entries: 4096 (order: 3, 32768 bytes)
Buffer-cache hash table entries: 16384 (order: 4, 65536 bytes)
Page-cache hash table entries: 65536 (order: 7, 524288 bytes)
CPU: Before vendor init, caps: 0183f9ff 00000000 00000000, vendor = 0
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 128K
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: After vendor init, caps: 0183f9ff 00000000 00000000 00000000
CPU:     After generic, caps: 0183f9ff 00000000 00000000 00000000
CPU:             Common caps: 0183f9ff 00000000 00000000 00000000
CPU: Intel Celeron (Mendocino) stepping 05
Enabling fast FPU save and restore... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: Intel
PCI: PCI BIOS revision 2.10 entry at 0xfb330, last bus=1
PCI: Using configuration type 1
PCI: Probing PCI hardware
Unknown bridge resource 0: assuming transparent
PCI: Using IRQ router PIIX [8086/7110] at 00:07.0
Limiting direct PCI/PCI transfers.
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
apm: BIOS version 1.2 Flags 0x07 (Driver version 1.14)
mxt_scan_bios: enter
Starting kswapd v1.8
VFS: Diskquotas version dquot_6.5.0 initialized
pty: 2048 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with MANY_PORTS MULTIPORT SHARE_IRQ SER
IAL_PCI ISAPNP enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
Real Time Clock Driver v1.10e
block: queued sectors max/low 167693kB/55897kB, 512 slots per queue
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz PCI bus speed for PIO modes; override with idebus=xx
PIIX4: IDE controller on PCI bus 00 dev 39
PIIX4: chipset revision 1
PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:pio, hdd:pio
HPT366: onboard version of chipset, pin1=1 pin2=2
HPT366: IDE controller on PCI bus 00 dev 70
PCI: Found IRQ 7 for device 00:0e.0
PCI: Sharing IRQ 7 with 00:0e.1
PCI: Sharing IRQ 7 with 00:10.0
HPT366: chipset revision 1
HPT366: not 100% native mode: will probe irqs later
    ide2: BM-DMA at 0xcc00-0xcc07, BIOS settings: hde:pio, hdf:pio
HPT366: IDE controller on PCI bus 00 dev 71
PCI: Found IRQ 7 for device 00:0e.1
PCI: Sharing IRQ 7 with 00:0e.0
PCI: Sharing IRQ 7 with 00:10.0
HPT366: chipset revision 1
HPT366: not 100% native mode: will probe irqs later
    ide3: BM-DMA at 0xd800-0xd807, BIOS settings: hdg:pio, hdh:pio
hda: IBM-DJNA-371350, ATA DISK drive
hdb: ATAPI CD-ROM DRIVE 40X MAXIMUM, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
blk: queue c034f660, I/O limit 4095Mb (mask 0xffffffff)
blk: queue c034f660, I/O limit 4095Mb (mask 0xffffffff)
hda: 26520480 sectors (13578 MB) w/1966KiB Cache, CHS=1754/240/63, UDMA(33)
ide-floppy driver 0.97.sv
Partition check:
 hda: hda1 hda2 hda3
Floppy drive(s): fd0 is 1.44M
Comment 3 Michael Fulbright 2002-01-15 16:28:31 EST
Does this happen in fdisk on an installed system?
Comment 4 Chris Ricker 2002-01-15 16:53:38 EST
No
Comment 5 Michael Fulbright 2002-01-16 14:34:41 EST
Could you give a hardware description of the machine having the problem please?
Comment 6 Chris Ricker 2002-01-16 14:55:29 EST
What do you want, other than the dmesg output already included?

They're Celeron 500s, IBM hard drives, 256 megs ram, Nvidia video cards, 2 nics
(1 3c905c-txm, the other a linksys tulip clone)
Comment 7 Michael Fulbright 2002-02-21 15:25:40 EST
I haven't seen this problem from anyone else, closing it because its not a
serious threat to functionality.

Note You need to log in before you can comment on or make changes to this bug.