Bug 57722 - sis730 motherboard: installer kernel panic: Attempted to kill init!
sis730 motherboard: installer kernel panic: Attempted to kill init!
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
athlon Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-20 04:57 EST by jonathan.buschmann
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 19:55:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jonathan.buschmann 2001-12-20 04:57:26 EST
Description of Problem:
This has already been posted to a RH support forum: 
http://www.redhat.com/WebX?224@99.sk9CaFyjSfe^0@e1bd@.ee79440

Linux Net4.0 for Linux 2.4
  Based upon...
  invalid operand: 0000
  CPU: 0
  EIP: 0010:[<c01122d1>]
  EFLAGS: 00010206
  eax: c0101cc8 ebx: cc800000 ecx: 8da32000 edx: c0101000
  esi: c1232000 edi: 0bff0000 ebp: 00000000 esp: c1337f54
  ds: 0018 es: 0018 ss: 0018
  Process swapper (pid: 1, stackpage=c1337000)
  Stack:
  0bff1000 00001000 0bff0000 c00fc390 8da32000 c0101cc8 00000010 cc800000
  c1232000 0bff0000 00000000 c0112523 cc800000 3f7f0000 c1232000 00000000
  cd22184c c00fc390 00000014 cc800000 c123184d c023a700 0bff0000 c123184d
  Call Trace:
  [<cc800000>] [<c0112523>] [<cc800000>] [<cd22184c>] [<cc800000>]
  [<c0105000>] [<c0105201>] [<c0105000>] [<c0105642>] [<c01051f8>]
  Code: 0f 0b 8b 5c 24 14 85 db e9 31 01 00 00 89 f6 b8 f4 ff ff ff
  <0> Kernel panic: Attempted to kill init!

Version-Release number of selected component (if applicable):


How Reproducible:
Always

Steps to Reproduce:
1. boot: text
2. 
3. 

Actual Results:
As above

Expected Results:


Additional Information:
	
My hardware is a sis730s based motherboard with a 1G Duron processor.
Comment 1 jonathan.buschmann 2001-12-20 04:59:37 EST
I tried:
boot: linux noathlon
with no change.
Comment 2 Arjan van de Ven 2001-12-20 05:02:16 EST
Is this one of those boards with built-in video but without videoram ?
I've seen one board where the bios forgot to mark the main memory it used for
videoram as "reserved" so that both linux and the videocard use it.

Could you try passing

mem=xxxM

where xxx is 33 Mb less than the actual memory you have (or whatever you set up
for "shared" video memory in the bios)
Comment 3 jonathan.buschmann 2001-12-20 15:18:37 EST
arjanv@redhat.com you guessed it right.
that solved it.  booting with a reduced mem.
I don't know if high praise is allowed in bug reports, but well I've done a
dozen RHinstalls over about 6 yrs, never had a problem installing, and never
made a bug report. 5 minutes after my first it was solved. 
thanks
Comment 4 Alan Cox 2003-06-07 19:55:08 EDT
BIOS problem so one we can't fix ourselves

Note You need to log in before you can comment on or make changes to this bug.