Bug 57725 - linux/limits.h: No such file or directory
linux/limits.h: No such file or directory
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-20 05:40 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 13:57:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-12-20 05:40:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 (Macintosh; U; PPC)

Description of problem:
After uppgrading glibc-devel to glibc-devel-2.1.3-23 some header files apear 
to be missing or wrong. The error when confg mod_ssl is reported as:
gcc -c -DHAVE_CONFIG_H -I.   backupfile.c
In file included from /usr/include/bits/posix1_lim.h:126,
                 from /usr/include/dirent.h:206,
                 from backupfile.c:38:
/usr/include/bits/local_lim.h:27: linux/limits.h: No such file or directory
make: *** [backupfile.o] Error 1

Reinstalling glibc-devel-2.1.3-23 using --force does not fix this problem.

Version-Release number of selected component (if applicable):
glibc-devel-2.1.3-23 for RedHat 6.2

How reproducible:
Always

Steps to Reproduce:
1. Download Apache 1.3.20 or 1.3.22 and mod_ssl tarballs
2. tar xzf apache and mod_ssl
3. ./configure (with no options)
4. make


Actual Results:  Apache standard ./configure
gcc -I.  -I../os/unix -I../include   -DLINUX=22 -DUSE_HSREGEX -DUSE_EXPAT -
I../lib/expat-lite -DNO_DL_NEEDED `../apaci` -DPOSIX_MISTAKE   -c -o 
regcomp.o regcomp.c
In file included from /usr/include/bits/posix1_lim.h:126,
                 from /usr/include/limits.h:30,
                 from /usr/lib/gcc-lib/i386-redhat-linux/egcs-2.91.66/
include/limits.h:117,
                 from /usr/lib/gcc-lib/i386-redhat-linux/egcs-2.91.66/
include/syslimits.h:7,
                 from /usr/lib/gcc-lib/i386-redhat-linux/egcs-2.91.66/
include/limits.h:11,
                 from regcomp.c:5:
/usr/include/bits/local_lim.h:27: linux/limits.h: No such file or directory
make[3]: *** [regcomp.o] Error 1
make[2]: *** [subdirs] Error 1
make[2]: Leaving directory `/hd0/home/hal/apache-build/apache_1.3.22/src'
make[1]: *** [build-std] Error 2
make[1]: Leaving directory `/hd0/home/hal/apache-build/apache_1.3.22'
make: *** [build] Error 2

Result when trying to apply mod_ssl:
Configuring mod_ssl/2.8.5 for Apache/1.3.22
 + Apache location: ../apache_1.3.22 (Version 1.3.22)
 + Auxiliary patch tool: ./etc/patch/patch (local)
./configure:Error: Building of 'patch' tool failed:
-------------------------------------------------
creating ./config.status
creating Makefile
creating config.h
config.h is unchanged
gcc -c -DHAVE_CONFIG_H -I.   backupfile.c
In file included from /usr/include/bits/posix1_lim.h:126,
                 from /usr/include/dirent.h:206,
                 from backupfile.c:38:
/usr/include/bits/local_lim.h:27: linux/limits.h: No such file or directory
make: *** [backupfile.o] Error 1


Expected Results:  An Apache binary

Additional info:

It is not possible to compile a program.
Comment 1 Need Real Name 2001-12-20 13:08:09 EST
The missing file is there in /usr/i386-glibc20-linux/include/linux/
But the ref seems to be wrong.
#) find / -name limits.h
find: /proc/6/fd: Permission denied
/usr/include/limits.h
/usr/lib/gcc-lib/i386-glibc20-linux/egcs-2.90.29/include/limits.h
/usr/lib/gcc-lib/i386-redhat-linux/egcs-2.91.66/include/limits.h
/usr/lib/bcc/include/asm/limits.h
/usr/lib/bcc/include/limits.h
/usr/i386-glibc20-linux/include/limits.h
/usr/i386-glibc20-linux/include/linux/limits.h
Comment 2 Alan Cox 2002-12-15 13:57:19 EST
Missing kernel-includes package.


Note You need to log in before you can comment on or make changes to this bug.