Bug 57747 - ZeroDivisionError updating status bar
ZeroDivisionError updating status bar
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.0
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
: 57985 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-20 13:31 EST by Richard Henderson
Modified: 2015-01-07 18:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-22 08:37:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Henderson 2001-12-20 13:31:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.7 i686)

Description of problem:
Getting headers for available packages...
Traceback (innermost last):
  File "/usr/sbin/up2date", line 1014, in ?
    main()
  File "/usr/sbin/up2date", line 341, in main
    sys.exit(batchRun(argObj.getLong("list"), pkgNames, fullUpdate))
  File "/usr/sbin/up2date", line 900, in batchRun
    printCallback, percentCallback)
  File "/usr/sbin/up2date", line 820, in runInteractive
    progressCallback = percentCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 1570, in
getUpdatedPacka
geList
    refreshCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 827, in getHeaders
    hdr, sourcetype = doCall(headerSource.getHeader, pkg)
  File "/usr/share/rhn/up2date_client/up2date.py", line 287, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 123, in getHeader
    header = source.getHeader(pkg, progressCallback = progressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 475, in getHeader
    buffer = self._readFD(fd, size, filePath,
progressCallback=progressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 435, in _readFD
    speed = bytesRead / (curTime - startTime)
ZeroDivisionError: float division


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
"up2date -l" plus good network latency.

Additional info:
Comment 1 Adrian Likins 2002-01-07 18:28:15 EST
*** Bug 57985 has been marked as a duplicate of this bug. ***
Comment 2 Pete Zaitcev 2002-03-23 01:05:54 EST
Where can I get an RPM for testing, for s390 architecture?
Comment 3 Pete Zaitcev 2002-04-01 12:06:40 EST
Seems to be fixed in 2.7.65-7.x.3. The darn thing now
requires python-clap for some reason, so download that too.
Fortunately, it's a noarch package.

I think Adrian should have made a note about the version
when he marked the bug MODIFIED.

If rth agrees, it's time to mark CLOSED.
Comment 4 Matt Jamison 2003-05-22 08:37:56 EDT
closing bug.

Note You need to log in before you can comment on or make changes to this bug.