Bug 577478 - parted-2.2 is available
parted-2.2 is available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-27 07:13 EDT by Upstream Release Monitoring
Modified: 2010-03-30 08:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 08:56:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2010-03-27 07:13:28 EDT
Latest upstream release: 2.2
Current version in Fedora Rawhide: 2.1
URL: http://ftp.gnu.org/gnu/parted

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_Release_Monitoring
Comment 1 acount closed by user 2010-03-27 22:05:18 EDT
GNU parted NEWS                                    -*- outline -*-

* Noteworthy changes in release 2.2 (2010-02-26) [stable]

** Changes in behavior

  The default alignment (--align option) for newly created partitions has
  been changed to optimal.

** New features

  The ped_device_get_*_alignment() functions now return a sane default
  value instead of NULL when the so called topology information is incomplete.
  The default minimum alignment aligns to physical sector size, the default
  optimal alignment is 1MiB, which is what vista and windows 7 do.

** Bug fixes

  Parted no longer uses a physical sector size of 0 or of any other
  value smaller than the logical sector size.

  dos: creating an HFS or HFS+ partition in an msdos partition table
  used to set the partition type to 0x83.  That is wrong.  The required
  number is 0xaf, and that is what is used now.

  gpt: read-only operation could clobber MBR part of hybrid GPT+MBR table
  [bug introduced in parted-2.1]

  gpt: a read-only operation like "parted $dev print" would overwrite $dev's
  protective MBR when exactly one of the primary and backup GPT tables was
  found to be corrupt.
  [bug introduced prior to parted-1.8.0]

  sun: the version, sanity and nparts VTOC fields were ignored by libparted.
  Those fields are properly initialized now. The nparts (number of partitions)
  field is initialized to 8 (max. number of sun partitions) rather that to a
  real number of partitions. This solution is compatible with Linux kernel
  and Linux fdisk.

  "make install" no longer installs tests programs named disk and label

  libparted: try harder to inform kernel of partition changes.
  Previously when editing partitions, occasionally the kernel would
  fail to be informed of partition changes.  When this happened future
  problems would occur because the kernel had incorrect information.
  For example, if this problem arose when resizing or creating a
  new partition, then an incorrect partition size might be displayed
  or a user might encounter a failure to format or delete a newly
  created partition, respectively.

  libparted: committing a disk that was returned by ped_disk_duplicate
  would always result in ped_disk_clobber being called (and thus the first
  and last 9KiB of the disk being zeroed), even if the duplicated disk,
  was not returned by ped_disk_fresh().
Comment 2 Hans de Goede 2010-03-28 10:10:30 EDT
parted-2.2 is available in F-13 and later already. Next time please check for availability before filing a bug, thanks!
Comment 3 acount closed by user 2010-03-28 10:19:58 EDT
(In reply to comment #2)
> parted-2.2 is available in F-13 and later already. Next time please check for
> availability before filing a bug, thanks!    

latest version in koji is 2.1 builds http://koji.fedoraproject.org/koji/packageinfo?packageID=75

where is 2.2 ?
Comment 4 acount closed by user 2010-03-28 12:59:14 EDT
definitly F-13 brings *2.1*  http://cvs.fedoraproject.org/viewvc/F-13/parted/

And there is NO parted-2.2 in anyplace of Fedora servers.

-thanks-
Comment 5 Hans de Goede 2010-03-28 17:05:12 EDT
I'm sorry, you are completely right. I got confused by your inclusion of the parted Changelog for 2.2, as we do already have most of those fixes / new features

(I'm active in parted upstream and most of them were written by me for Fedora 
 issues).

To be precise we are only missing the following from the NEWS file you included:
  dos: creating an HFS or HFS+ partition in an msdos partition table
  used to set the partition type to 0x83.  That is wrong.  The required
  number is 0xaf, and that is what is used now.

  sun: the version, sanity and nparts VTOC fields were ignored by libparted.
  Those fields are properly initialized now. The nparts (number of partitions)
  field is initialized to 8 (max. number of sun partitions) rather that to a
  real number of partitions. This solution is compatible with Linux kernel
  and Linux fdisk.

That does not mean that we should not upgrade and sync with upstream rather then carrying backported patches, but it hopefully explains what confused me.

Re-opening.
Comment 6 Hans de Goede 2010-03-30 08:56:58 EDT
parted-2.2 is on its way to rawhide, closing.

Note You need to log in before you can comment on or make changes to this bug.