Bug 57750 - AIC7896 timeout when booting up after fresh install
AIC7896 timeout when booting up after fresh install
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-20 16:06 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-21 02:07:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-12-20 16:06:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
I have a VA Linux 2230 box, with 440GX chipset, AIC7896 SCSI chipset.  
Yes, that one.  There is only 1 processor in the machine, and the install 
went perfectly.  However, when I boot up the machine, it hangs with the 
old timeout error.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Turn on the machine
2.  Watch it boot.
	

Actual Results:  SCSI timeout errors galore.

Expected Results:  The system should boot up normally.

Additional info:

I attempted the normal 440GX/AIC7xxx workarounds to no avail.  I tried 
passing APIC=0 to the kernel, but it was already a 1 CPU system with the 
uni-cpu kernel.

I'm using GRUB, but that shouldn't make any difference since it gets past 
that point.
Comment 1 Need Real Name 2001-12-20 16:48:23 EST
When booting up and trying to load the AIC driver, I get:

scsi0 Adaptec  AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.2.4/5/2/0
<Adaptec AIC-786/7 Ultra2 SCSI host adapter
scsi1 Adaptec  AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.2.4/5/2/0
<Adaptec AIC-786/7 Ultra2 SCSI host adapter
scsi : aborting command due to timeout : pid 0, scsi0, channedl 0, id 12, lun 0 
Inquiry 00 00 00 ff 00

Vendor QUANTUM MODEL:Atlas_V__9_WLS REV: 0230
Type: Direct-Access    ANSI SCSI revision:03

scsi : aborting command due to timeout : pid 0, scsi0, channedl 0, id 12, lun 0 
Inquiry 00 00 00 ff 00
Comment 2 Jeremy Katz 2001-12-20 16:53:00 EST
440GX based boards are not supported; reassigning to kernel
Comment 3 Arjan van de Ven 2001-12-21 02:07:36 EST
On 440GX motherboards you NEED to install the SMP kernel.
You can either do this by "upgrading" again, and then pick the smp kernel
or go into rescue mode (from the cd) and install the smp kernel in the chroot there
Comment 4 Need Real Name 2001-12-25 00:54:26 EST
The assertion regarding the SMP kernel is correct.  Once the SMP kernel was 
forced onto the system (even though it only has a single CPU installed), all 
behaved as expected.  This also explained why I had installed 7.2 on a 440GX 
system with AIC-7896 before and it worked--the previous system has 2 CPUs 
installed.

Perhaps this should become part of the Errata for 7.2 and future versions?

Thanks for the effort.

Note You need to log in before you can comment on or make changes to this bug.