This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 577632 - openssh-server.i686 0:5.3p1-19.fc12 fails to start
openssh-server.i686 0:5.3p1-19.fc12 fails to start
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
12
i686 Linux
low Severity high
: ---
: ---
Assigned To: Jan F. Chadima
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-28 09:25 EDT by Syed Amer Gilani
Modified: 2010-04-17 08:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-17 08:23:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Syed Amer Gilani 2010-03-28 09:25:19 EDT
Description of problem:
After an update from openssh-server.i686 0:5.2p1-31.fc12 to the newest stable packet the sshd binary fails to start.

Version-Release number of selected component (if applicable):
openssh-server.i686 0:5.3p1-19.fc12

How reproducible:
fails every time

Steps to Reproduce:
1. yum install openssh-server
2. /etc/init.d/sshd start
  
Actual results:
sshd starten: Auto configuration failed
3078874760:error:0E07606D:configuration file routines:MODULE_RUN:module initialization error:conf_mod.c:235:module=engines, value=openssl_engines, retcode=-1
                                                           [FEHLGESCHLAGEN]

Expected results:
sshd starten:                                              [  OK  ]

Additional info:
The sshd_config is the default one.
On another Fedora Installation i have it works fine, so maybe its a Hardware related thing. The Machine it fails on is a Intel Atom.

I fixed it for the moment with:
yum downgrade openssh openssh-server openssh-clients
Comment 1 Jan F. Chadima 2010-04-09 08:20:07 EDT
It seems to be a problem with openssl engine configuration. The newest version of openssh read openssl's config. 

Try to consult "man 5 config".
Comment 2 Syed Amer Gilani 2010-04-17 08:23:07 EDT
/etc/pki/tls/openssl.cnf was outdated.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.